Skip to Content

Save Scenario Script not Working

Hi Gurus,

I have a quick doubt here. Need help on it ASAP. Its been a while since I started with the bookmark functionality.


This is the Error I am getting.


Multiple markers at this line

- Couldn't resolve reference to Member 'saveBookmark'.

- missing ';' at 'Bookmark'

Error if I try running it.

Bookmark an analysis application: SAP BusinessObjects Design Studio 1.3 - YouTube

http://scn.sap.com/community/businessobjects-design-studio/blog/2014/08/04/insides-on-bookmarking

I have gone through all possible links on this, a couple I have provided above, however, I am still not able to

find a solution on it.

The version details of the tool used are here.

SAP BusinessObjects Design Studio

Release 1.3 (Version: 13.0.3.201405141058)

I am using the BW queries and its run on netweaver portal.

What could be the issue?

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Sep 15, 2014 at 09:50 AM

    Hi Both,

    I did some research on this. And it looks like the bookmark related functionality isn't supported in the Netweaver mod, It runs only in local and BI platform.

    Correct me if am wrong.

    Regards,

    Sara

    Add comment
    10|10000 characters needed characters exceeded

    • HI Sara,

      this is correct, bookmarks are working as of 1.3 release only in local and BIP mode, NetWeaver mode support is planned to be released in 1.4 (RTC plan for November).

      Regards, Karol

  • Sep 15, 2014 at 06:03 AM

    Hi Sara,

    You have just missed small element in code. Just use ; after the variable defining statement. Each statement in Design Studio should be separeted by ";".

    Like

    var name = INPUTFIELD_NAME.getValue();

    Bookmark.savebookmark(name);

    Hope this solves your problem.

    Regards

    Sateesh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sara,

      I think there is no problem in code, Could you please restart DSL Bridge (or delete it and recreate).

      And enable trace for further investigation of Error if needed.

      Thanks and Regards

      Sateesh

  • Sep 15, 2014 at 08:46 AM

    Hi,

    from the errors in script it looks like you do not have a correct installation of release 1.3. Also the loops are not correctly recognized in this script.

    Please do following:

    * uninstall design studio client

    * download 1.3 SP1 and install again.

    -> you should see a version 13.1.0....

    Karol

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 15, 2014 at 09:57 AM

    Hi Sara,

    Are you logged into Netweaver platform?

    I guess Bookmarking is still not supported in 1.3 in Netweaver mode.

    Thanks & Regards,

    Pinakshi


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sara,

      I am working on Design Studio in BI platform mode. And i dont have idea on Netweaver. As you says may be Bookmark functionality is not working in Netweaver platform.

      Regards

      Sateesh