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Former Member

Webi reports showing all numbers as ############

Hello,

I am upgrading a BO 3.1 Webi report to BO 4.1 using Upgrade Management Tool, there was no error in the upgrade process.

However when I run the Webi report, all numbers in the Webi report are showing as ############.

When I refresh the Webi report, all numbers still are still showing ############.

What could be the reason and how could I fix the issue.

Thanks!

George

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4 Answers

  • Sep 11, 2014 at 03:04 PM

    Hi George,

    It could simply be that columns are not large enough to display values with font parameters.

    Did you try to increase width of columns or change font size ?

    If this doesn't work then you should try to create a new report with a basic table to make sure it works fine there.

    Regards,

    Loic

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    Former Member
    Sep 11, 2014 at 03:06 PM

    Hi George

    Please increase width of the report columns. It will resolve the issue.

    -Anuj

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    Former Member
    Sep 11, 2014 at 03:17 PM

    Hi Loic & Anuj,

    It is not column width issue, the numbers are pretty small, it should have enough space to display.

    Plus, it is not only one place, it is all numbers in the Webi report.

    Thanks!

    George

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    • sometimes the query objects are not aligned, click edit on webi 4.1 report to see if ts pointing to the right query. if it is. copy the webi report and then re assign it to the same query see if that works.

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    Former Member
    Sep 11, 2014 at 03:55 PM

    I followed the suggestions to open the report in Webi Rich Client, make the column wider. Now I see the ############ are actual #UNAVAILABLE.

    So the actually question is all numbers are showing as #UNAVAILABLE.

    Any ideas?

    Thank you very much guys!

    George

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    • The below threads may also be useful :

      Additional note 1603634 - BI 4.0: #UNAVAILABLE in Web Intelligence report using BEx query when adding a variable based on a dimension

      Symptom

      #UNAVAILABLE is displayed for all measures (key figures) when a variable based on a dimension is created and added to a report based on a BEx query.

      Environment

      SAP BusinessObjects BI Platform 4.0 SP0.x

      Reproducing the Issue

      1. In Information Design Tool, under Repository Resources, create a BICS connection to a BEx query.
      2. Launch Web Intelligence from BI Launchpad and create a new document based on that BEx query.
      3. In the query panel, drag and drop some dimensions and measures. Execute the report.
      4. In the Design view, create a new report variable using a dimension.
      5. Add the newly created variable to the report block.
      6. All measures (key figures) display #UNAVAILABLE.
      7. Refresh the query, but #UNAVAILABLE is still displayed for all measures.

      Cause

      This behaviour is by design.

      Resolution

      The following explanation has been provided by Product Group:

      "Imagine the formula for the dimension returns the fist letter of the country:
      All countries starting with 'A' would aggregate into a single line: but this is local aggregation and the measure are defined to be aggregated on the back end.
      When you are sure that the formula will not produce aggregates (1 value of the formula <-> 1 single value for the dimension) then you can use the workaround with the detail*.
      This will not be fully addressed with 4.1: only for measures that aggregate on 'Sum'. They will be no longer delegated, but aggregated locally with 'Sum'."

      *Possible workaround: define the variable as a detail, and associate it to the original dimension. Included it in the block along with the original dimension, which needs to be formatted to be hidden.