Skip to Content
author's profile photo Former Member
Former Member

PDO Layer error on Display Purchase Order

Hi,

We have our SRM7 system configured to send an email to the PO creator at the end of the approval workflow - this email has a link

to display the purchase order but when we click this link we get the following error:

"PDO Layer error"

I've checked through the notes and there's a few issues around the POWL queries, our POWL queries are working fine in the client

though and we can display the PO with no issues so I'm reluctant to change these. Is there a specific POWL that the email link uses?

The link is in the following format :

http://oursapsystem/nwbc/srm/~canvas;window=app/obn/po.display/?sap-client=500&SAPSRM_BOID=005056AA1D2…

The BOID corresponds to the correct GUID.

We are using NWBC for HTML, I've looked at roles/authorisations but not sure that's the issue as we can display the PO no problem within

SRM.

The following pdf describes it and recommends to implement PL18, we're on PL40.

https://websmp210.sap-ag.de/~sapidb/012003146900000494452011E/PDO_Layer_error.pdf

Seems like the "~canvas" tag is the issue?

Regards,

Tony

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 11, 2014 at 01:34 PM

    Hi Tony,

    What is your exact version of SRM and support pack level? Also the following KBA may be of some help if you haven't checked it already:

    1749594 - "PDO Layer error" message

    Kind regards,

    Conor

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Conor,

      Thanks for the reply.

      We are using SRM7 EPH3 and NWBC Patch level 40.

      I had a look at that note but as i said our POWL query is working fine in SRM only when we click the email link do we get this error, not sure if changes here will affect that.

      Note 2061880 relates to the issue - i've done the recommended change LPD_CUST (the boid is hardcoded in here) but this hasn't resolved the problem.

      I've raised an OSS with SAP.

      Regards,


      Tony

  • author's profile photo Former Member
    Former Member
    Posted on Sep 29, 2014 at 11:16 AM

    Still waiting on a resolution from SAP.

    However we can display the purchase order ok when we use this link

    http://xxx-xxx-xxx/sap/bc/webdynpro/sapsrm/wda_l_fpm_oif?sap-

    client=500&sap-ep-tstamp=20140926123714&sap-ep-version=7&sap-

    ie=EmulateIE8&sap-language=EN&sap-nwbc- etc

    Is there any specific reasoning that SAP uses the OBN link in the email???

    http://xxxx/~canvas;window=app/obn/po.display/

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.