Skip to Content
avatar image
Former Member

The method "SELFITEM->SendTaskDescription" not sending mail if ‘Long Mail Title’ Indicator is set in SWPA

Hi Experts,

The method "SELFITEM->SendTaskDescription" not sending mail if ‘Long Mail Title’ Indicator is set in SWPA.


This issue is faced in EHP7 environment earlier it was working fine.


My analysis is FM SWW_SRV_MAIL_SEND is called to send mail. Inside this FM, system reads the SWPA setting & based on long title value it is sending mail.If value of l_long_title is blank then all things are working fine.


Following is code of method SEND ((CL_SWF_UTL_MAIL_FACADE)

*- check if document has recipients at all

lt_recipients = lo_send_request->recipients( ).

if lt_recipients is initial.

lo_send_request->delete( ).

ls_t100msg-msgid = 'WZ'.

ls_t100msg-msgty = 'E'.

ls_t100msg-msgno = 619.

raise exception type cx_swf_run_wim

exporting

t100_msg = ls_t100msg.

else.

*- Send document

call method lo_send_request->send( ).

endif.


The issue is lt_recipients table is blank in SEND method, this table is filled in method IF_OS_STATE-INIT.

The recipient table is not filled because the current GUID is not available in table BCST_RE.

I have refreshed buffer in So16, SWU_OBUF.

Is there any other buffer needs to be clear?

I checked following notes for long mail title

2045292 E-mail send step does not send any HTML e-mails - Status : Not relevant for our issue

1609811 Mail send step: mail title increased to 255 bytes - Status : cannot be implemented

1685032 Configuration: Background work items with jobs - Status : cannot be implemented

1658491 Enhancement SWPA: Long mail title - Status : cannot be implemented


Is there any other buffer needs to be clear?

Please suggest if any note is required to implement or any setting needs to be done in system.


Thanks & Regards,

Manjiri Kamthe

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 10, 2014 at 02:47 PM

    Hi Manjiri

    Are the email NOT being Sent "entirely" out OR are you not able to see them in SOST?

    Have you confirmed if the recipients are getting the email......even though it is not visible in SOST?

    Note 1830899 mentions the restrictions of using "Long Mail title".... the emails cannot be buffered in the ou.boundt queue (SOST) and are sent as "Express" without waiting for the send process (the background job to push emails out of SOST)

    Please do a test to your email address and see if it actually reaches the email client (without showing in SOST).

    regards,

    Modak

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Modak Gupta

      Hi All,


      The issue resolved.


      The FM SX_INTERNET_ADDRESS_TO_NORMAL is changed in EHP7 upgrade.

      I resolved this issue by maintaining parameter in SOST SX_SMTP_ADDRESS_CHECK as OLD.

      Also there is note 2000533 which can resolves email id issue.


      Thanks & Regards,

      Manjiri Kamthe.