Skip to Content
avatar image
Former Member

Group header not getting displayed

I am trying to do a group by on several fields in a crystal reports table

In group expert, for Group By, I select

Investigator Name

Request Date

Rank

Department

College

After suppressing details, when I try to display the results in report

I get

GH1 - John Smith

GH2 - 09/01/2011

GH3 - Assistant Professor

GH4 - Dept of Computer Science

GH5 - College of Arts & Sciences

In the very next section I get

GH2 - 09/01/2012

GH3 - Assistant Professor

GH4 - Dept of Computer Science

GH5 - College of Arts & Sciences

Why is GH1 not getting displayed in the preview section? How can I get it to display?

Thank You

Shariq

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Sep 10, 2014 at 05:36 AM

    Hi Shariq,

    The GH1 prints 'only once' for 'one group'. In your example above, John Smith has multiple records and hence GH1 appears once while the others appear for each iteration.

    If you want the name on GH1 to repeat for each subsequent group section, just suppress the GH1 section and move the name to GH2. You can create a new GH2a and 2b section to handle this where 2a holds the name and 2b holds the Date.

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 09, 2014 at 09:37 PM

    Hi Shariq,

    I hope your report works perfect but some confusion.

    Not doing any suppress conditions then why GH1 is not displaying. Suppress any blank section in section expert using GH1

    Field having any blank or null data.

    I suggest one thing you need check the data for particular below details:

    Request Date

    Rank

    Department

    College

    Please share the information ASAP ..

    tHANKS,

    DJ

    Add comment
    10|10000 characters needed characters exceeded