Skip to Content
avatar image
Former Member

communication via the wrong network interface

Hi experts,

I hope you can help me with an issue of our 4.6C system running on Windows 2003 R2.

When a user is establishing a connection via SAP GUI, this connection is made to serverprd on port 3600 in the server LAN - works fine.

However as soon as the communication goes to Port 3200, the communication goes via the backup LAN, which is configured as a 2nd network interface.

I tried to find out why the communication switches to the backup interface - I changed the order of the interfaces in the Windows network configuration, but no change.

The server has 2 IPs:

DNS Name                  IP                            Interface

serverprd                    server LAN

serverprd-backup       backup LAN

There a re no host entries in the c:\windows\system32\drivers\etc\hosts

Does anyone has an idea what could else be tried?

Thank you for any ideas...


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 26, 2014 at 07:40 PM

    after we changed the order of the interfaces in the network setting and restarted the system, the communication went through the correct interface.

    Thank you Isaías, your answer was very helpful!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member


      that's the prefered way I want to see here.

      the etc/hosts modifications are local one's I don't like, because they interfere with DNS based configurations.

      To be more precise:

      The root problem here is the Logon Group based connection of SAPGui is using an IP Address for the gui connections which is reported by the message server. The message server itself get's the ip address information of the dispatcher of the instance listed. The IP address reported by the dispatcher is the first one reported by the windows operating system (following the order of interfaces).



  • avatar image
    Former Member
    Sep 09, 2014 at 07:45 AM

    this normally has  nothing to do with etc/services entries.

    SAP processes are typically listening to all network addresses (see command netstat -ano).

    Whenever a connection is made from one computer to the next one, the client computer (that is the computer on which the program is running which establishes the connection) will automatically determine the optimal connection to the destination.

    If there are interfaces used you have designed for different purposes you have to change the routing information on the computers. This is typically done using the command line tools route.exe or netsh.exe (interface IPV4 route).

    Please refer to a more network oriented forum to get help about setting up appropriate network routing on your boxes.


    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 08, 2014 at 03:11 PM

    Hi Philipp,

    Could you please share the services file from location windows/system32/drivers/etc for analysis.Also share a log file for which shows using different interface IP for port 3200.



    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      here is the relevant extract from the firewall log...

      Step 1: communication goes to the server via the correct interface on Port 3600 (gSAP_36)

      Step 2: connection is established via Port 3200 (correct behaviour) but via the backup interface

      the service entries are as follows

      sapgw00s 4800/tcp

      sapgw10s 4810/tcp

      sapmsPRD   3600/tcp

      The services are all working properly - only the communication stream is going wrong.

      Best regards


      firewall.jpg (13.2 kB)
  • Sep 11, 2014 at 03:04 PM

    Hello Philipp,

    When an SAP ABAP instance starts, it must determine which is the "primary IP address" of the server, which will be the IP address accessible by the end users.

    The issue could be occurring because SAP is getting the wrong IP address, or due to inappropriate name resolution on the Messge Server host.

    The best way to solve this is to edit the "hosts" file of all SAP servers of this system (the server where the Message Server runs, and the servers of all instances). The "hosts" file is located at "c:\windows\system32\drivers\etc".

    At this file, add lines "forcing" the desired IP address to the hostname of the servers. For example:

    * You have three servers for the affected SAP system: dbci, app1 and app2;

    * The IP addresses accessible by the end users are, and, respectively;

    * You need to add the following to the "hosts" file of all three servers (and ensure that there are no conflicting entries):     dbci     dbci.your-internal.domain     app1     app1.your-internal.domain     app2     app2.your-internal.domain

    After this has been done, you must stop SAP, clear the DNS cache (by running the command "ipconfig /flushdns"), and then start SAP again.

    Best regards,


    Add comment
    10|10000 characters needed characters exceeded