Skip to Content
author's profile photo Former Member
Former Member

SFTP receiver channel Archive filename isssue

Hi,

I am working on SAP SFTP adapter (SAP PI7.4).

SFTP receiver channel is placing the file with correct filename as generated by dynamic configuration code but sftp channel is adding an extra .txt extension in filename while archiving.

Example: Actual Filename: CCBGI.SSEN_TNG.BATCH0000000000000052.sft

At archive folder : CCBGI.SSEN_TNG.BATCH0000000000000052.sft.txt

Please suggest resolution for this.

Thanks & Regards,

Nida Fatima

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    Posted on Sep 08, 2014 at 06:01 AM

    Hi Nida,

    You can change the file name in SFTP using the ASMA configuration, in this way you would need ESR development.

    To use ASMA configuration, check these links:

    SAPTechnical.COM - Dynamic File name using ASMA (Adapter Specific Message Attributes) in XI / PI

    Dynamic file name and directory in Receiver File Adapter - summary of possibilities - Process Integration - SCN Wiki

    Another solution is to use OS command.

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2014 at 01:10 PM

    Hi,

    Have you had a look at this blog?

    SFTP Adapter in PI 7.3x

    Regards,

    Jannus Botha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 05, 2014 at 01:45 PM

    Hi Nida,

    Here is my assumption of your interface

    You are using UDF in message mapping for dynamic configuration of file name.

    In the receiver SFTP channel, apart from placing the file on the target SFTP server directory (where you are getting proper file name from dynamic configuration) you also wish to archive the file on the local application server for reference purpose for which you must be using standard Archiving Module and provided by SAP in Module tab of SFTP adapter to do this.

    If my assumption are correct then i would suggest check and confirm if you have specified name as .txt in that. Also, if you are facing same file name issue on SFTP server directory also then i would suggest check the UDF code once if there you have put .txt extension.

    If the above does not help then, please provide more details about dynamic configurations so that we can analyse.

    Thanks,

    Amit

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Amit,

      For archiving we are not using any module. I have used standard archiving functionality provided in channel.

      File placed at sftp server has correct filename but the file which is archived at our local server is adding additional .txt in complete filename.

      So i don't think there is any issue with UDF .

      Thanks & Regards,

      Nida

      Archive.PNG (12.4 kB)
  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2014 at 03:10 PM

    Hi,

    In the Processing tab make File Type as Binary.

    Please find the screenshot:

    This will avoid .txt format.

    Hope this helps!

    Regards,

    Souvik


    Capture.PNG (2.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2014 at 12:22 PM

    Hi Souvik,

    I can't see any option for filetype in SFTP receiver channel. Could you please recheck and confirm with screenshot.

    Regards,

    Nida

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.