Skip to Content
0
Aug 28, 2014 at 07:51 AM

MS SQL Server ODBC Connection On Linux

1010 Views

Hi All,

I am badly stuck with configuration of MS SQL Server ODBC connection on SUSE Linux 10. I am almost tried everything I got from SAP notes but still getting ODBC Lib Data Direct drivers could not be loaded IES 10901.

ENV: SAP BO 4.0 SP7, MS SQL SRV 2008

Here is what I have tried so far:

1) Modified env.sh under /install_dir/sap_bobj/setup and added the line in bold.

":${BOBJEDIR}enterprise_xi40/linux_x64/odbc/lib:${BOBJEDIR}enterprise_xi40/$SOFTWAREPATH32/odbc/lib"

The line should look like this

LIBRARYPATH="$LIBDIR:$LIBDIR32:$WCSCOMPONENTDIR:$PLUGINDIST/auth/secEnterprise:${CRPEPATH64}:${CRPEPATH}:${MWHOME}:$PLUGINDIST/desktop/CrystalEnterprise.Report:

${BOBJEDIR}enterprise_xi40/$SOFTWAREPATH32/ras:${BOBJEDIR}mysql/lib:${BOBJEDIR}enterprise_xi40/linux_x64/odbc/lib:${BOBJEDIR}enterprise_xi40/$SOFTWAREPATH32/odbc/lib”

2) We have .odbc.ini file in the home directory of our BO user on linux. Added following DSN entry (Same DSN is created on client and odbc connection has been created on the universe using this DSN:

boeadm01:~> vi .odbc.ini

[DSN_NAME]

Driver=/opt/sapboe/sap_bobj/enterprise_xi40/linux_x64/odbc/lib/CRsqls24.so

Description=DataDirect 6.0 SQL Server Native Wire Protocol

HostName=SQL Server Hostname

Database=SQL DB Name

QuotedId=Yes

AnsiNPW=No

3) We then added the environment variables and LIBPATH in BO user .profile file.

boeadm01:~> vi .profile

#Sql Server Environment

ODBCINI=$HOME/.odbc.ini

export ODBCINI

LD_LIBRARY_PATH=/opt/sapboe/sap_bobj/enterprise_xi40/linux_x64/odbc/lib

export LD_LIBRARY_PATH

4) Did echo to check the LIBPATH

boeadm01:~> echo $LD_LIBRARY_PATH

/opt/sapboe/sap_bobj/enterprise_xi40/linux_x64/odbc/lib


5) Modified sqlsrv.sbo under /install_dir/sap_bobj/enterprise_xi40/dataAccess/connectionServer/odbc

<Parameter Name="Use DataDirect OEM Driver" Platform="Unix">Yes</Parameter>

6) Restarted BO node.

Tried creating a new webi report and got the error mentioned above.πŸ˜”πŸ˜”πŸ˜”

Please help!!!

Thanks,

Anshul