Skip to Content
Former Member
Aug 27, 2014 at 10:23 AM

roll up to initiatives not (completely) working


Hi everyone,

The context

We're running a PS module on one system and a PPM module (CPRXRPM 500_702) on another.

In PS, we have a bunch of PS Projects with lots of WBS, Networks and Activities, on which there are costs.

In PPM, we have one Item per PS Project (they're properly linked in rpm_obj_link), and these Items are related to some Initiatives and some Buckets, everything being related to a single Portfolio.

What we're trying to do

We're using /RPM/FICO_INT_PLANNING to roll up costs from the PS Projects into the PPM Items, Buckets and Initiatives. We're using option "Integr., Planning and Rollup" of that program.

All the configuration to enable this has been done and double-checked, as per the official documentation.

The issue

While roll up on Buckets and Items are OK, roll up on Initiatives is not. When looking into NWBC's financial views, we have zeroes everywhere, instead of the sum of the related items.

We noticed that the corresponding entry in financial view table V_INM_INIT_DB is missing, despite the data in the related tables being complete. It's as if we just need that one entry to be created for the NWBC to work.

The only way we managed to make it work is by changing the financial period breakdown on the Initiative (from annual to something else, then back to annual). Then if we run the roll up again it works. However, we have a lot of Initiatives to handle and will have more in the future, so a manual fix is not a good enough solution. Besides, this works only when done via NWBC (see below).

What we already tried to solve it

- we triple-checked the configuration of both systems, everything is fine

- we installed notes 2023535, 1996720, 2007537, 2057988 and 1909853 in hopes it would fix the roll up program, it didn't help our issue

- we used /RPM/PLAN_INT_PREP on both Items and Initiatives in hopes it would generate the Initiatives' views, it made no difference

- we tried defining the period breakdown on both the Item and the Initiative upon their creation (instead of letting the system set the default)

- we reproduced the period breakdown trick in code by using INM_INITIATIVE_MODIFY, but it does not "unblock" the Initiative like it does in NWBC

- we tried to find where and when the financial view is created, but V_INM_INIT_DB is not used anywhere in the system apparently!?

- searching online for infos on both V_INM_INIT_DB and /RPM/FICO_INT_PLANNING did not bring much information

My questions to you

- anybody met a similar issue previously? How did you solve it?

- any ideas on where to look or what to try next? We're kind of out of ideas here, and running short on time, as we'll start the user testing soon.

I'm currently trying to trace and debug what's happening in both the roll up program and NWBC, to see if I can understand what's wrong. But this is a lengthy process, especially considering I don't even know what to look for. So any help and ideas would be greatly appreciated!

Kind regards,