Skip to Content
author's profile photo Former Member
Former Member

Start Routine issue when data divided across data packets

Hi,

I have a peculiar problem. Have not found any satisfactory answer yet

I have to delete duplicate Material Numbers before loading from Oracle Database into Material Info object.

I try to do this thru START ROUTINE. The Number of entries is around a million. Hence it gets divided into data packets. Looks like BW only takes one packet at a time when it loads data into the DATAPAK internal table. Hence though I am able to delete duplicate entries in same data packet, when the same material number is coming in a separate data packet, it is giving problems.

How do I overcome this. How can I get a truly Global Internal Table where I can load all the data carry out the deletion operation for the entire dataset.

Any Help Deeply Appreciated.

Regards

arvind

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 11, 2005 at 03:54 PM

    hi,

    - delete duplicate in oracle before go to bw ? it's good to 'clean' data in earlier staging.

    - can try in infopackage choose 'psa...' (the 3rd option), subsequent update, and mark 'ignore duplicate' ?

    - another way maybe load to psa only first, then abap code to delete the duplicate, then load to master data

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Paolo,

      The issue is that I have to pick up only the Material ,along with other attributes , which has got the highest version number. Hence I have got to first load it into some internal table, sort it by Material Number and Version Number and then pick up each Material having the highest version number.

      Thanks for your suggestion. It would have definitely worked for other scenarios. Just that my requirements are a bit different

      Regards

      arvind

  • author's profile photo Former Member
    Former Member
    Posted on Dec 12, 2005 at 03:34 PM

    Hi Arvind,

    In the infopackage setting go to processing tab and choose the option "Only PSA" and also choose the check boxes "Update Subsequently in Data Target" and "Ignore Double Data records".

    Hope this will help.

    Cheers,

    Balaji

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 11, 2005 at 03:23 PM

    Hi arvind,

    cant you increase the data package size so that all the records come into one data package? dont know this is optimal but you can try.

    Sriram

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.