Skip to Content
avatar image
Former Member

Which version of Java for SAP NetWeaver 7.02 in Windows Server 2008

Hi ,

     I want to install SAP NetWeaver 7.02 (not SP6) in Windows Server 2008 R2 x64, but I don't know which version of Java I should install first, I have downloaded the following four types of Java:

j2eesdk-1_4_02_2005Q1

j2sdk-1_4_2_09_windows_i586

j2re-1_4_2_19-windows-i586-p

j2sdk-1_4_2_19-windows-i586-p

    But, I don't know which type I should choose to install first.

    Thanks for help!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 20, 2014 at 02:40 PM

    Hi  Shelley,

    For JDK requirements please go with j2sdk-1_4_2_19-windows-i586-p. Ensure that it is 64-bit compatible since your OS is 64-bit.

    Regards,

    Deepak Kori

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Deepak,

          Thanks!

          Yes, I'm sure my OS is 64-bit Windows Server 2008 R2, only install j2sdk-1_4_2_19-windows-i586-p, other three types of Java needn't be installed is OK?

  • avatar image
    Former Member
    Aug 20, 2014 at 03:06 PM

    Hi Shelly,

    The 3rd party jdks are no longer supported, for 7.02 systems you need to be using the SAPJVM 4, which was built to replace the vendors.

    Note 1495160 has more information.

    Kind regards,
    Cathal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Cathal,

          Thanks for your help!

          But the document of SAP installation says:

      • If you start sapinst the first time, you will be logged off your operating system and afterwards prompted for the installation directory of JRE 1.4.latest or 1.5.0_22 (tested).
        Do not use 1.6.x! The installation will start, but not finish.

      JRE 1.4.latest or 1.5.0_22 (tested): it means I should install j2re-1_4_2_19-windows-i586-p, is it right?

      捕获.PNG (43.5 kB)