Skip to Content
avatar image
Former Member

ICM_HTTP_CONNECTION_BROKEN

Hello All

we are facing persistend connection-error in OAC0 when test-Connectiong a new-installed ContentServer.

It says:

„Error in HTTP Access: IF_HTTP_CLIENT->RECEIVE 1 ICM_HTTP_CONNECTION_BROKEN

               Message no. CMS166"


The ContentServer is installed with User „CS-Admin“, which is in group „Administrators“ on an English Windows 2008 R2, 64bit.

The installation went fine and finished with no errors.

After installation the driver is registered successfully with odbcreg as follows:

     "odbcreg.exe CSMaxDB -i -p "E:\sapdb\SDB\db\pgm" -d sdbodbcw.dll"

An idea is, that there still might be failours in right-administrations

For example CS-Admin had no rights for some partitions. Also some directories where excluded from permission inheritance (Berechtigungsvererbung) after first installation. Furthermore the user CS-Admin had no rights to execute the odbcreg-command.

Also the contentserver.ini was not editable for CS-Admin after installation,

But finally there was no error in installation-process (?!).

And all this is solved now by the Person, who has installed Windows on that machine.

I have reinstalled the ContentServer after this with CS-Admin, I have also deinstalled and again installed the contentserver, but the connection-error remains.

The Network-Connection seems to be fine. SAP-Ping (OS01) is ok. Also Telnet works fine.

Please do not doubt the IIS-Installation, this is ok.

Can somebody give advice, how we can find out, what breakes up the connection between SAP-Server and CS-Server?

Cheers

Tobias




Additional Informations:

Systemdata: Linux / SYBASE / NW731 SPS11

Kernel: 721 PL201

No entries in Syslog (SM21)

No entries in RFC-Trace (SM59) after activation of Trace for RFC-Destination „SAPHTTPA", also with rdisp/TRACE=2

No entries in „cs_trace.txt", only request by URL in Webbrowser generates entries in cs_trace.txt.

  1. ContentServer.ini: [ContentServer]

KeepConnection=0

AdminSecurity=0

Security=0

ContRepRoot=E:\usr\sap\contentserver\ContRep

Storage=ContentStorage.dll

ContentStorageHost=CSAHL02

ContentStorageName=SDB

LogRequests=1

ResponseTrace=1

Log404Response=1

FullTrace=1

Report RSHTTP05 is OK

Report RSHTTP20 gives "Response Data 0"

Checked notes:

794919 - Fehleranalyse: ICM_HTTP_TIMEOUT und interner Fehler

164203 - Probleme mit SAPHTTP

761387 - Support-Informationen fuer den SAP Content Server

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 28, 2014 at 09:46 AM

    Hello everybody,

    thanks for help, we found the error located in Firewall:

    Even when telnet to port 1090 is stable, the connection can be cut by the firewall afterwards.

    The firewall first checks, which kind of application wants to connect to the port. When this is clear, the firewall is cutting connection anyway, if the Port is not opened by definations. Maybe this is a new feature in Firewall-technologies...

    Thanks so far.

    TG

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 13, 2014 at 07:09 PM

    Maybe check RFC connections or might have to do with the port assignment.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      http://x.x.x.x:1090/ContentServer/ContentServer.dll?serverInfo

      works fine:

      serverType="SAP HTTP Content Server";serverVendorId="Copyright SAP AG, All rights reserved 1998, 2001";serverPatch="0";serverStatus="running";serverStatusDescription="";serverDate="2014-08-13";serverTime="17:31:23";startUpDate="2014-08-13";startUpTime="17:31:22";lastAccessDate="2014-08-13";lastAccessTime="17:31:22";

      And as Report RSHTTP05 gives no errors, there is everything OK with RFC's I think...


           SAPHTTP check

           Check RFC destination SAPHTTP...

           ... OK.

           Ping RFC destination SAPHTTP...

           ... OK.

           Check RFC destination SAPHTTPA...

           ... OK.

           Ping RFC destination SAPHTTPA...

           ... OK.

  • Aug 13, 2014 at 07:30 PM

    Hi Tobias,

    Was there anything in ICM logs ?

    Regards,

    Divyanshu

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Tobias,

      Not really, I was looking the reply which says ICM HTTP connection broken

      Error in HTTP Access: IF_HTTP_CLIENT->RECEIVE 1 ICM_HTTP_CONNECTION_BROKEN

      That was the reason I asked you to even check ICM logs.

      Regards,

      Divyanshu

  • avatar image
    Former Member
    Aug 13, 2014 at 07:59 PM

    Regarding  1829887 - Error in HTTP Access: IF_HTTP_CLIENT->RECEIVE 1 HTTPIO_PLG_CANCELED Message no. CMS166

    I tried. I have added the entry in SDOKPROF, but the Connectiontest say's then:

    HTTP error:

    Message no. CMS025

    Diagnosis

    Error in accessing via HTTP

    This might lead to

    1293399 - 500 (Internal Server Error) in CSADMIN

    but ODBC driver has been registered successfully

    To me, this seems not to bring any solution, right?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 13, 2014 at 08:03 PM
    Please find: SAP Message Number  0120050409 0000036823 2014
    Add comment
    10|10000 characters needed characters exceeded

  • Aug 14, 2014 at 09:03 AM

    Hi Tobias

    Can you please check this one is set ?, as per OSS note 977091 - CS 640 Driver

    regards

    Swami


    Add comment
    10|10000 characters needed characters exceeded

  • Aug 15, 2014 at 03:56 PM

    Hello

    First check whether the repositories mentioned in this SAP note are present in the system.

    308977 - Repositories BIE_QMM, BIE_NET, HME_CONTENT,ED,A2 and B2

    If yes follow the SAP note.

    Also try to maintain the Content Server hostname and the IP address in the hosts file of the server where ABAP is running.

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded