Skip to Content
0

Should general stats show in Trial HCP SAP API Management?

Jan 23, 2017 at 08:33 PM

114

avatar image
Former Member

I have setup the trial SAP API Management in HCP and am able to query both a REST and SOAP API via the provided API Management URL's. I can setup and cause policies to block (i.e. verify using an api key) but there are no usage statics showing up in the Analyze tab. Am I missing something, is this a bug, or a limitation of the trial version? The API documentation I have seen implies that no additional setup is required in order to see basic usage statistics and have yet to come across any documentation on what the limitations are between the production and trial versions, if any.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member
Jan 31, 2017 at 09:48 PM
0

Analytics should be fixed for all Trial users now. Please check again in your account. If there is still something wrong we can look into your account more deeply.

Regards,
Elijah

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jan 26, 2017 at 06:22 PM
0

Hi Nicholas,

Yes, analytics should be available in the Trial as well, showcasing what usage has come across your landscape. There are not many limitations to the trial (Developer Portal analytics are not available on Trial for example) environment, as we want to give Business user and Developers as full an experience as possible.

When you say no usage shows up, do you mean the tabs tell you there is no data, or it simply appears empty? Can you provide a screenshot of what you are seeing? Also perhaps in a shorter time frame (try Past Hour, and Past Day as well as the default which I believe is past week).

Regards,
Elijah

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Elijah,

Thanks for your help. The tabs are showing "no data" and "not in use" for the APIs I have setup. Is there some additional setup step I'm missing?

I have the API's setup and can Test via the built-in Test tab in API management to get a response. When I check the Application's (JAVA) access logs the queries show up there.

One additional thing I noticed is if I debug the API there is a step which suggests stats are being gathered so I'm not sure why they aren't posting to the dashboard.

Cheers,

Nick

api-day.png (63.1 kB)
api-logs.png (45.2 kB)
api-debug.png (14.6 kB)
0
avatar image
Former Member
Jan 31, 2017 at 01:06 AM
0

Hi Nick,

This is most curious. Did you recently register your API Management trial? I just did some testing on a newer account, and I also faced some trouble viewing Analytics data, while my existing account is working fine. We recently made some PostClientFlow changes, that may have affected newly onboarded users. Thank you for bringing this up.

I will bring this up for a deeper look as to if this is a systemic problem, and hopefully see if we can come up with a correction soon.

Regards,
Elijah

Share
10 |10000 characters needed characters left characters exceeded