Skip to Content
author's profile photo Former Member
Former Member

Datasource assignment Disappears

Hello,

I am in an infosource and I assign a datasource, I have the communication structure, Transfer Rules, Transfer Structure all set up.

I then save and activate.

When I leave the infosource (back out, Log off, etc) I then go back into it and my datasource assignment is blank and all the transfer structure and Transfer Rules are gone.

Please help, I am not sure why this is occuring. The infosource used to work fine.

Thank you!

Nick

Add a comment
10|10000 characters needed characters exceeded

Related questions

9 Answers

  • Best Answer
    Posted on Dec 07, 2005 at 03:48 PM

    Looks like all this DSs one by one were assigned to the IS and activated. You DS in modified version seems to be the culprit of the behavior noticed by you.

    I think if you choose the DS you need and activate TRs, you'll restore everything.

    Best regards,

    Eugene

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2005 at 02:46 PM

    Hi,

    Did you upgrade SAP front end GUI lately? If you are, that is the reason. Everythig works perfectly but graphically you wouldn't see. Something like this happened to all of my ODS object settings after we upgraded GUI. Hope this helps.

    Rao.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 07, 2005 at 04:39 AM

    Hi Nick,

    If you enter the infosource maintenance screen, transfer structure/transfer rules part of the screen is collapsed. Just click on a transfer structure/transfer rules icon at the bottom. TS & TRs should appear.

    Additional check: you should see in the infosources tree the IS itself, the source system below it, and an infopackage(s) below the SS (if you have created it).

    If you see them, everything is in place.

    Best regards,

    Eugene

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 07, 2005 at 11:29 AM

    Hi,

    Once you assigned datasource to infosource and activated properly,there is no chance to disapper the TR and TS, until unless you delete it.So refresh the tree and check it.

    Thanks

    Surendra

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2005 at 02:06 PM

    Hey Guys thanks for your posts!

    I did make sure to expand the "Transfer Structure/Transfer Rules" portion so it was visible. However there is nothing listed underneath that section. I see the source system however the Datasource box is blank, there are no defined transfer Rules, and nothing in the Assign.InfObjct-field. There is nothing listed under the DataSource/Trans. Structure tab. It is as if I am setting it up new.

    When I look at the infosource from the outside (RSA1>Infosources) without actually going into it I can see that the source system assignment is there and all my infopackages are listed there as well.

    I am still able to load data through the infosource with these infopackages. It seems as though it is setup and working however the GUI doesn't display any of the information that is supposed to be displayed within the infosource under the "transfer_structure/Transfer Rules".

    Has anybody seen this occur? Thanks for your help and suggestions thus far!

    Nick

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 07, 2005 at 02:53 PM

    Hi Nick,

    Actually, it may happen.

    Situation: you activated TRs, but then made some changes and saved them without activation (‘Modified’ status). Since there is an active version in the system (generated transfer program), you can load data. But, there is no assignment of active source system (and TRs), that’s why TRs are not seen when you enter IS. If you enter the TRs directly (not from IS) you’ll see TRs in revised version. If so, just activate TRs again.

    Best regards,

    Eugene

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2005 at 03:06 PM

    Hello Eugene,

    How do I enter the TR's directly? I have always just entered them from the InfoSource

    Thanks,

    Nick

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2005 at 03:34 PM

    Hello Eugene,

    I think we may be getting somewhere now....

    I did as you said (double click on the source system beneath the IS), and when i click through the datasources that I can select by using the dropdown. i have 4 DataSources listed. I select them 1 by 1 and the status for each one is as listed:

    1_CO_PA2000010 - copa sand Modified(Saved)

    1_CO_PA2900010_DS - COPA 0010 w/ Dorel Suisse ACTIVE (Saved)

    1_CO_PA2900010_DS_A-1_CO_PA2900010_DS_A Account Based Active(Saved)

    1_CO_PA2900010_DS_N - COPA-SND_TEST Active(Saved)

    How can I have 3 datasources showing up as Active? The only one I want to work with is the 2nd one listed. "1_CO_PA2900010_DS - COPA 0010 w/ Dorel Suisse"

    Maybe the system is confused?

    Where do you think I go from here?

    Nick

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2005 at 04:03 PM

    Hello Eugene,

    I couldn't thank you enough for sticking with me to resolution on this problem. You pointed me in the right direction!

    Since I had so many datasources that were active for this infosource I took the following steps to remove them so I could be back to the only one that I needed. I had so many for testing purposes.

    I double clicked on the source system underneath the InfoSource that had the datasource assignment disappearing problem.

    I selected one by one the datasources that were assigned and I clicked the 'Delete datasource assignment' (trashbin icon).

    I did that for each datasource except the one that i wanted to work with going forward.

    Once I had deleted the extra datasources I selected the datasource that I had wanted all along and saved it and then activated.

    I am on the right track now!

    Thanks again!

    Nick

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.