Skip to Content
avatar image
Former Member

Shared memory slots

Good day,

I'm having the following error in the JAVA AS server stack;

No more available Shared Memory Slots. Increase shared memory in JStartup configuration. Or decrease number of used regions. Failed region: BIWEBAPPS:odocResourcesUSER.R3_DATASOURCE.TEBBETI, caused by: com.sap.bc.proj.jstartup.sadm.ShmNoMemoryException: Cannot alloc cache 'BIWEBAPPS:odocResourcesUSER.R3_DATASOURCE.TEBBETI' (rc = 2 out of memory).#

The heap size has already been increased till 4096.

The shared pool is already been increased:

- For pool 10: 208000000

- For pool 40: 486000000

The system is Dual Stack. Version of the JAVA AS server is 730

Could you please help me with this issue ?

Thank you in advance

Best regards,

Anatolii

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 25, 2014 at 03:30 PM

    Hello

    The reason for this error is that shared memory provides space for a configurable limited number of applications and aliases. If more applications are deployed than the shared memory can fit, a
    ShmNoMemoryException is thrown when an application is started. To avoid these messages you can increase the size of this table using the ConfigTool. In the menu "View", enable "Expert Mode". At the
    instance level, there is a tab named "Shared Memory". You can try to increase the value for property "Thread", from the current 800 to 2500 for instance.

    SAP NOTE 1748779 also provides more information.


    Cheers,

    Tapan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello

      Forgot to mention that you need to increase cache parameter values also. You can configure twice the current value.

      Cheers,

      Tapan

  • Jul 27, 2014 at 07:57 AM

    Hi,

    You will need to increase cache parameter values here. The cache parameter can be increased by doing the following:

    Configtool -> View menu -> enable Expert mode -> go to cluster-data on
    the left tree -> template -> instance. On the instance go to Shared
    Table tab. Here you will find the Caches property.

    Increase the value (make sure that it is not higher than the value for jstartup/numCaches
    in the profile), Save and restart the cluster.

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2014 at 12:24 PM

    Thank you very much for your help.

    It really solved the issue.

    Best regards and take care.

    Anatolii

    Add comment
    10|10000 characters needed characters exceeded