Skip to Content
author's profile photo Former Member
Former Member

No option to "provision manually" to GRC Access Request

We are using GRC 10 SP13 and are not able to get the provision manually option to work in the system.

The setting have been enabled:

-Maintain System Provisioning Config setting in SPRO set to Manual Provisioning under Auto Provisioning for specific system as well as Globally.

-In MSMP in the stage definition task settings for the path for a new request set "Allow manual prov".

My understanding from the documentation is that the 1st approver would have the option to "provision manually" instead of submit, but when they open the workflow inbox request there is no such option. There is only the submit button. Where is the "provision manually" option and how do we enable?

Don

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Jul 25, 2014 at 05:40 AM

    Dear Don,

    I have never configured manual provisioning but what I can see from the settings. You have to ensure that at the last stage of your path manual provisioning is activated in your MSMP configuration. Also make sure that the workflow is activated after changing that field.

    As you have mentioned manual provisioning must be enabled in provisioning settings.

    Personally I assume that the workflow needs to be activated once again as you are still missing the button. After activation you have to create a new workflow as all the existings are having the old configuration.

    Regards,

    Alessandro

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Alessandro Banzer

      Hi Alessandro

      After further investigating, I think the issue may be due to incorrect configuration of the connection settings.

      IMG -> Common Component Settings -> Integration Framework -> Maintain Connection Settings

      Now I am able to set up the AUTH integration sub-scenario by following note 1654282.

      The note however, does not indicate how to configure the legacy connector for the PROV scenario.

      There error seems to disappear when I mess around with this setting for a request in the work inbox however does not provision.

      If you go into the PROV sub scenario, and then into Scenario-Connection type link you see that there is no connection type for FILE available. Further, if you go to SE24 for the list of classes it looks like there is only FILE classes for the AUTH scenario and SUPMG relating to CL_GRAC_AD*_FILE*

      How do you configure PROV scenario for legacy connector? I can't see a way to do this?

  • Posted on Jul 25, 2014 at 04:40 AM

    Once approvers approve it system wont provision automatically.

    The provision has to be done manually.

    Regards,

    Prasant

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Prasant

      Thank you for the reply.

      1. The system is provisioning the access automatically even though the setting is put on manually provision in the global and system specific automatic provisioning.

      2. According to note 2014626 there should be a button that appears for the approver that says "provision manually". This is not appearing in our requests.

      3. How do we get the button to appear and for manual provisioning to be enabled?

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.