Skip to Content
0

Problems while using oData Service Catalog

Jan 23, 2017 at 02:31 PM

149

avatar image

Hey,

I try to connect backend system to the HANA Cloud Platform. The setup for Cloud Connector and destination at HCP was succesful. Now I want to select some oData Service from the Service Catalog in the WebIDE. Against my experience it opens an popup instead of loading the list with available Services. The popup asks for the credentials, but after entering this, the popup was reloaded without another effect. I´m sure about entering the correct credentials as well by setup of the destination as by entering the data in the popup.

Closing the popup effects the following message:

Does somebody know this issue and therefore a solution?

Thanks in advance!!!

Tim

unbenannt.jpg (12.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Masayuki Sekihara
Jan 24, 2017 at 04:18 AM
1

Hi Tim,

If you did not specify the authentication in the destination setting, the backend user and password will be asked.

Double check the user and password by logging on to the backend via SAPGUI. The user maybe locked because of many logon fails.

Then you can test the OData service directly from browser. Replace the [ACCOUNT] and [DESTINATION NAME].

https://webide-[ACCOUNT]trial.dispatcher.hanatrial.ondemand.com/destinations/[DESTINATION NAME]/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json

Regards,

Masa / SAP Technology RIG

Share
10 |10000 characters needed characters left characters exceeded
Liz Simmons Jan 23, 2017 at 09:56 PM
0

We saw this many times at our university while teaching our students to use HCP. The "Authentication failed" part of the message indicates that your Username and password used with the Destination may be the problem. When (if) prompted, make sure these are the same as the account information you entered into the Destination when it was created, and that it matches your login information also.

If that didn't fix the problem, the students were able to make it work by using a different account to log into HCP and set up the Destination.

Share
10 |10000 characters needed characters left characters exceeded
Michal Keidar
Jan 25, 2017 at 01:02 PM
0

Make sure that the credentials you're entering are of the backend and not for HCP

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I have the same problem as Tim, and I'm sure I entered the same credentials as the backend system, could be the user locked? is there a way to unlock it?

Thanks in advance!

Ignacio

0

Contact your system admin in order to unlock it

0