Skip to Content
author's profile photo Former Member
Former Member

Error while running multitenancy management tool

I wanted to replicate the reports, universe and universe connection.

But am getting the following error when i run the MTM.

[ERROR] An error occurred while updating Web Intelligence document <reportname>. The detailed error message is while trying to invoke the method or

g.eclipse.emf.ecore.EObject.eClass() of a null object loaded from local variable 'eObject'.

What could be the reason?

I have given below parameters like

templateToken=$Template$

# (Mandatory) Logon information

cms=<cmsname>

auth=secEnterprise

user=administrator

pwd=<password>

optionIncludeUniverses=True

optionIncludeConnections=True

optionIncludeCategories=false

optionIncludeProfiles=false

optionIncludeEvents=false

optionIncludeAccessLevels=false

optionUseSharedUniverses=false

optionUseSharedConnections=false

## (Optional) Document folder template

templateContentFolder=CA Reports/CA ITCM Reports/CA ITCM 12.8.100.1001/$Template$ Folder

## (Optional) Universe folder template

templateUniverseFolder=CA Universes/$Template$ Folder

## (Optional) Connection folder template

templateConnectionFolder=$Template$ Folder

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 21, 2014 at 03:45 AM

    Hi,

    Check attached link if this can helps you.

    Multitenancy Management tool setup, new features in BI 4.1

    Regards,

    Amit

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 22, 2014 at 10:13 AM

    Is anybody else faced this kind of issue?

    MTM is working fine with shared universe option but when i am trying to replicate the universe and connection am facing this issue.

    The issue also says

    "An error occurred while updating Web Intelligence document All Citrix XenDesktop Computers. The detailed error message is while trying to invoke the method org.eclipse.emf.ecore.EObject.eClass() of a null object loaded from local variable 'eObject'."

    "The object with id number '10411' cannot be deleted, modified or scheduled because it does not exist.

    "Failed to refresh tenant object(s) or update shared object(s). (MTM 00011)"

    This is what i got in log file but there is no more details to debug the error.

    thanks

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      am able to replicate the universe, reports and connection by setting the parameter

      abortANDRollback=false

      (instead of true) which i did and got the issues which i mentioned in my first post.

      But in this case even the content is getting replicated and reports are working fin am getting the below error.

      An error occurred while updating Web Intelligence document <report name>. The detailed error message is An internal error occurred while calling 'initInstance' API. (Error: ERR_WIS_30270).

      The system was unable to update object <report name> (id=15,145)

      Does any body got this issue?

      Please let me know am i missing or doing anything wrong.

      thanks

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.