Skip to Content

Finding incoming idoc in PI

Apologies... PI newbie here.

We have an incoming idoc, which comes via PI into our R3 system. In R3, transaction WE02 I can see that this idoc has not arrived.

How can I find in PI if it is stuck there for some reason. I have tried looking in the Runtime Workbench, but have not been able to find this. Please can someone give clear steps to go about finding this object.

Thank you in advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Jul 18, 2014 at 08:02 AM

    HI Glen,

    Please check in transaction code SM58 in XI system.

    Add a comment
    10|10000 characters needed characters exceeded

    • Thank you. I tried this transaction but it doesn't show the idoc. I have the idoc number from the sender system, but on our system this hasn't arrived so we have no idoc number. Normally when we receive the idoc it is assigned another number, but for some reason the idoc hasn't come through even though on the sender side they have a message that it has been successfully sent.

  • Posted on Jul 18, 2014 at 09:57 AM

    Hi Glen,

    Can you please specify what is your sender system here ?

    Generally IDOC number of an incoming IDOC into PI System is same as that in sender system and when PI sends the IDOC say ECC the IDOC number changes.

    So if you are not able to find the IDOC in PI Sytsem then you probably need to check for the stuck entries in Sender System.

    Regards

    Vj

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Glen Anthony

      Hi Glen,

      Please check in we02 of sender SAP system. in control records segment, if the partner profile of recipient is maintained correctly.

      Check every thing on receiver partner profile starting from port no., LS, etc.

      port no. should be that of PI, which should be as maintained in IDX1, and LS should be the logical system for PI which is maintained in Partner profile (t-code WE20).

      Please let me know if this helps.

      Regards,

      Souvik

  • Posted on Jul 20, 2014 at 08:51 AM

    Hi Glen,

    May you already did, but ensure you are looking into the correct backend, I mean check Communication channel is pointing to correct SAP System and RFC used into that CC is also set up correctly. If there is no communication problems and channel is not alerting about any error double check your PI >>> ECC idoc connection:

    cheers,

    Roberto.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 21, 2014 at 08:04 AM

    Hi All,

    Thank you all for your help.

    I eventually found what I was looking for. In transaction SM21 the error message is sitting there. Therefore it seems when the IDOC is sent all looks good on the sender side, but because there was a missing segment in the IDOC it was not received, however the error clearly shows in SM21 on the receiving system i.e it has the name of the missing segment and everything.

    Thank you all once again for your help, it was much appreciated.

    Wish you all a nice week further. 😊

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.