Skip to Content
author's profile photo Former Member
Former Member

Some data is missed with Delta InfoPackage

Hi all,

I'm having an issue with a Delta load. When I execute the Init, data is properly loaded to BW, but since then, some fields in my datasource are not loaded to BW with Delta InfoPackage.

If I execute in RSA3 that datasource for one of the documents whose data is missed, everything looks correct.

I've deleted data in PSA and run the init again, and everything is loaded perfectly, but Delta is again missing some of the fields. Double-checking in RSA3 for some documents, everything looks fine.

InfoPackages init and delta and equal (except one is init, and theother one, obviously, delta).

Do you know why is this happening?

Thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Posted on Jul 16, 2014 at 01:17 PM

    Hi,

    Please find the documents which are not loading into bw.Take source team help and find those history.

    mean how they entered into SAP(ECC). its standard way or directly they entered into data source base tables.

    If they entered those entries other than normal way then data source won't pull those kind of records.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2014 at 01:23 PM

    Just to show you what's going on, in first screenshot, a document in RSA3 tx, second screenshot, same document in PSA in BW, with some gaps that should have data:


    1.jpg (82.8 kB)
    2.jpg (68.2 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Alberto,

      Have you verified that there is no filter or routine on the delta infopackage?

      Have you done the correct mapping for the missing fields, please verify your transformation and also the fields are selected in the datasource.

      Regards,

      Ashvin

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2014 at 01:38 PM

    Hi Alberto ,

    Can you clarify the below questions, so that we can help you .

    • Is it a standard Data source ? If yes, is it a enhanced or not ?
    • Is it a Generic Data Source ?

    Regards,

    Gokulkumar RD

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      We have double-checked enhancement and the problem is not in there, it calls standard processes and simple "select" commands. If the enhancement would have some issues, in INIT or in FULL infopackage, missed fields will be empty as well, but is not the case.

      So the problem comes in Delta infoPackage.

      We are quite astonished about this that just some fields are missed in Delta. Init and Full works fine, no register is missed, just some fields.

      Regards.

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2014 at 01:57 PM

    Hi Alberto,

    Was you delta queues(LBWQ/RSA7) cleared and rescheduled after adding new fields in data source ?

    Regards,

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 21, 2014 at 03:47 PM

    Hi Aberto,

    Double check your mapping to ensure that you have source-to-target mappings.

    Perhaps the fields are not connected.

    If everything checks out, consider opening an SAP custormer (OSS) note to the extractor, using your example.

    Not all fields in a delta extractor structure are available for export. You will need to reseach the specific extractor by its technical name in service.sap.com.

    Good luck,

    John Hawk

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.