Skip to Content
author's profile photo Former Member
Former Member

problem with Activating char InfoObject

Hi ,

Due to one transport One InfoObject(Master Data) is Inactivated in quality. I tried to activate this InfoObject manually and by using RSDG_IOBJ_ACTIVATE function module. But it is not activating & I am getting the error message like

1. Master data table is contains data

2. SID table is containing the data

So please let me know with out deleting the above data how can I activate that Infoobject.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2005 at 05:22 PM

    You can use transaction RSRV,there is primary treat in RSRV to make zero records in S table .

    RSDMD_CHECKPRG_ALL is also used to rebuild the SID tables..

    Then you can activate the masterdata .

    Hope it works ..

    Ravi

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 06, 2005 at 04:58 AM

    Hi,

    Looks like you try to transport an IO's version that differs from the existing already.

    I'd compare versions of the IO (active/revised/BC) in the IO maitenance screen and decide if this is correct that transported version differs. If not, I'd restore the old version and activate the IO.

    Best regards,

    Eugene

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      basically, this happens if a object has been deleted from the attributes or the data type has changed or the field length was decreased and the object contains data in the target system. So follow Eugene's instruction. Compare the objects. Another option might be the deletion of the master data of the object. But this is only possible if the data of all dataproviders that contain the object will be deleted too.

      regards

      Siggi

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.