Skip to Content

Error while triggering IDoc in PI7.4

Hi Experts,

My scenario is IDoc to File. The Sender IDoc adapter is working fine. Also when IDoc is triggered from ECC it is executed with status 03. But the IDoc has been stucked in SM58 with the following error:

No Endpoints registered for XI_IDOC_DEFAULT_PID on

system PI

where XI_IDOC_DEFAULT_PID is the program ID. I have done with the configurations in NWA for resource adapter,Destination too.

I have also used registered server program in RFC destination.

Can anyone let me know how to resolve this issue.

Cheers,

Neethu

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2014 at 09:24 AM

    Hi Neethu,

    I had this issue on our system.

    Please trigger a message in SAP ECC and then go to SAP PI Nwa to your logs.

    It will be under Logs Overview. Go to View and Select Developer Traces.

    Might just be that it cannot find a receiver on the integrated config.

    It will then give you more detail about the error that you get.

    Please also following the blog below on how to setup the inBoundRA etc.

    How to create and configure Sender Idoc AAE Scenario - PI 7.3

    Configuring PI 7.30 Java IDoc Adapter

    Regards,

    Jannus Botha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2014 at 09:44 AM

    Please follow the blogs given by Jannus Botha.

    Please follow this discussion it might help you. The sender channel holds the key.

    If error persists after you follow blogs and configure just keep the sender channel in manual mode and give the ECC system's parameters in the channel.

    PS-

    1-No need to make the JCO RFC Provider

    2- checl SMGW

    3- No need to give any gateway host and service in SM59 in ECC.

    4- Check the Unicode option in SM59 as told.

    5- And still if SM58 persists make channel as Manual configuration and give the ECC sysem details.

    Things to to do with InboundRA

    1- Destination - the destination you created (XI_IDOC_DEFAULT_DESTINATION)

    (I hope destination is created correctly with ECC details)

    2- MaxThreadCount- 5 or 10

    3- Local = true

    4- Program id- use same here and sm59

    5- in gateway host and service use PI's host and service

    Please let us know the results

    Thanks and Regards,

    Vikas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2014 at 09:31 AM

    Hello Neethu,

    Go to SM59 and in the TCP destination you maintained enable the unicode option.

    hope it will work


    Capture.JPG (43.6 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2014 at 10:30 AM

    Hi Neethu

    Please check if your TCP/IP RFC Connection is working.

    The Program ID provided in TCP/IP connection should also be mentioned in Resource Adapter.

    Regards

    Abhijit

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 17, 2014 at 06:47 AM

    You may also check if in PI NWA JCo Monitoring there are entries for your Program ID.

    If they are missing, please check if ACL is enforced. If so, you'll need to either switch ACL off (not recommended for production environments) or edit the ACL file according to your needs.

    SAP Gateway Security Files secinfo and reginfo - Security Settings in the SAP Gateway - SAP Library

    HTH

    Cheers

    Jens

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 28, 2014 at 08:59 AM

    Hi All,

    The issue is resolved now. I have changed the binding key property in resource adapter as PI_AAE_IDOC. It is used to associate the inboundRA resource adapter with the IDoc_AAE adapter and hence it should not be changed. It should be the default value always.

    Cheers,

    Neethu.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.