Skip to Content

Error sapjco3.dll

Hi gurus,


I tried to run Eclipse right after installation and adding the UI5 addon but it gave the attached error (no sapjco3 in java.librabry.path).

I tried the option from the link I found on SCN (), it does not help.

I also searched for sapjco3.dll file in the Eclipse folder but it did not find anything.

That is why:

  • I downloaded sapjco archive from SAP Marketplace
  • put it in a folder and extract
  • added that folder to the PATH system enviroment variable on Windows Server 2012
  • and then it gave the error about the version being too old (D:\sapjco\sapjco3.dll has version "720.612", but required is at least version "721.215”)

If you have any idea how we can move past this error it would be quite helpful.


Thank you in advance,

Marius

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Jul 16, 2014 at 07:47 AM

    I don't know if the explicite installation of jco was a good idea (as metioned in the linked discussion).

    Which Eclipse version do you run on which operating system?

    We have seen the "no sapjco3 in java.librariy.path" when Eclipse was not able to identify the operating system it runs on.

    For details check note 2041195.

    Regards, Felix

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.