Skip to Content
author's profile photo Former Member
Former Member

Loading XSD Schemas as External Definition

Hi all,

I am trying to load an XSD Schema into XI. As part of this schema is another external reference. I have also loaded this into XI. Looking at the 'External References' tab of the first message, I can see the reference to the second message. The problem is when I use this definition in my Message Mapping. There is not structure being seen. Has anyone else seen this before.

The XSD schemas can be loaded into XMLSpy fine.

Thanks

Martin

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2005 at 10:05 AM

    Hi,

    If you have tried generating this XSD using XMLspy,

    check the radio button "use complex elements" attribute instead of "individual elements". This will solve your problem.

    Regards,

    Siva Maranani

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.