Skip to Content

Charm Issue - Won't Migrate to Prod

Hi

We are testing ChaRM in our DEVELOPMENT Solution Manager.

We are testing ZMHF and pushing a transport from DEV > QAS > PROD.

The transport was successfully release and imported to QAS successfully. However, the import to PROD did not work.

There is two possible reasons why:

1) Our DEV and QAS systems are on EHP5. Our PROD system is on EHP7.  Please note, these are ALL test systems!!!!!! There is no way in the world we would have this setup in our real environments 😊 Our real environment is all EHP7 haha. Given this is purely for testing, we thought we would just test with three available dummy systems...two which happened to be EHP5 and one which was EHP7.

Anyway, in the Import Queue for Production it states "Does not match component version".  I'm assuming this is why the ZMHF does not import. I have also tried importing via the Task List (and have clicked the option to IGNORE INVALID COMPONENT VERSIONS)....this still didn't import.

My first question is should the Maintenance Cycle Task List import Urgent Corrections (ZMHF) as well? I believe it should?

I then tried importing via STMS into PROD (and checked the IGNORE INVALID COMPONENT VERSIONS) and it worked. I was then able to close the ZMHF in ChaRM.

Did it not import from ZMHF Directly and Maintenance Taks List because of the INVALID component versions?

OR

2) I noticed in the Alert Monitor for our PROD system the following:

Plug-in SAP_CTS_SERVICE is not registered in bootstrapper.

Also in the task list for the import I noticed the following:

What exactly is SAP_CTS_SERVICE Plugin or cCTS plugin??? Is this needed for ChaRM? Or is this warning something I can ignore? If it's 100% required, which systems does it need to be installed in?

Also, is this the reason why it didn't migrate to Prod?

Thanks so much!!!!!!!!


Shaun

Capture.JPG (41.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jul 16, 2014 at 10:49 PM

    All sorted.

    Installed the CTS plugin and the warning disappears...although this wasn't the issue.

    The test system we had setup had the wrong transport domain in SMSY.

    All good now.

    Cheers

    Add comment
    10|10000 characters needed characters exceeded