Skip to Content
avatar image
Former Member

Kapsel Plugin Install Issue

I'm trying to install the EncryptedStorage plugin into my cordova project.  I am getting the following error when executing the install:

Fetching plugin "C:\SAP\MobileSDK3\MobileSDK3\KapselSDK\plugins\encryptedstorage

" via plugin registry

Error: Failed to fetch package information for C:\SAP\MobileSDK3\MobileSDK3\Kaps

elSDK\plugins\encryptedstorage

    at C:\Users\chri225-sa\AppData\Roaming\npm\node_modules\cordova\node_modules

\cordova-lib\src\plugman\registry\registry.js:32:20

    at Request.cb [as _callback] (C:\Users\chri225-sa\AppData\Roaming\npm\node_m

odules\cordova\node_modules\cordova-lib\src\plugman\registry\registry.js:251:9)

    at Request.self.callback (C:\Users\chri225-sa\AppData\Roaming\npm\node_modul

es\cordova\node_modules\cordova-lib\node_modules\request\index.js:148:22)

    at Request.EventEmitter.emit (events.js:98:17)

    at Request.<anonymous> (C:\Users\chri225-sa\AppData\Roaming\npm\node_modules

\cordova\node_modules\cordova-lib\node_modules\request\index.js:886:14)

    at Request.EventEmitter.emit (events.js:117:20)

    at IncomingMessage.<anonymous> (C:\Users\chri225-sa\AppData\Roaming\npm\node

_modules\cordova\node_modules\cordova-lib\node_modules\request\index.js:837:12)

    at IncomingMessage.EventEmitter.emit (events.js:117:20)

    at _stream_readable.js:920:16

    at process._tickCallback (node.js:415:13)

Does anyone know how to fix this issue?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 09, 2014 at 05:27 AM

    Could you provide the steps you followed. Are you able to add other plugins in the app?

    To add the plugins:

    1. Make sure you are inside the project path and use the below command to add plugin to the project.

         cordova -d plugin add C:\SAP\MobileSDK3\KapselSDK\plugins\logon



    Midhun VP

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      It looks like the issue was related to the fact that I didn't install any cordova platforms.  Thanks for responding!