Skip to Content
0
Former Member
Jul 08, 2014 at 02:15 AM

Remote Logon Tab does not work

79 Views

Hello All,

We have a standard ABAP RFC Connection from our Dev system to our Prod system. We have maintained the connection with a Dialog user and the connection tests and authorization tests works fine. However when i test the 'Remote Logon' tab , nothing happens. We do not have an error message as well. So I turned on the RFC trace and the entries in the dev_rfc and dev_rd are as below;

Dev_RFC:

**** Trace file opened at 20140708 115142 AUS Eastern Standard Time, SAP-REL 640,0,414 RFC-VER 3 1368070 MT-SL

>>>> [1] SID : R/3 <ac: 844> K 10.200.1.31 >>> CLOSE abrfcio.c 2679 (86262062)

-{E3128536-7394-41B0-9DD0-FDE742DFD323}

==== Delta HO 0, 0 LOG DROPPED

DEV_RD:

*** trace for connection 6 enabled ***
GwIHandleRq: own_index: 0
GwIHandleRq: set act rq type DEALLOCATE
R3DEAL(86262062, cpic_vector=0, ..)
I am the client (0)
R3DEAL: state of conn/index 6/0: RESET
R3DEAL: send return code to cpic partner
GwISendRc: send appc_rc/sap_rc/status 18/0/0 to conn/target/client 6/1/20
GwGetMemory: allocated 000000000BCE6000 (len=192)
GwGetMemory: act_overflow_size = 460 (+ 192)
GwSetCPICState: state of conn/index 6/1: RESET
GwSendToClient: send data to conn/target/client 6/1/20

OUT:
----
ReqType : CPIC SysIdx : 20 ReqLen : 80 ReqId : 0
CommIdx : 13 ConnIdx : 6 ReqVer : 6 Trace : 0
conn : 6 wp_no : -1 ReqBlk : -1
RqType : SAP_SEND Prot : INT UID : 31769 Mode : 0
User : SapRc : 0 AppcRc : 18 ConvId : 86262062
Vector :
Info : SYNC_CPIC_FUNCTION
Info3 : GW_WITH_CODE_PAGE
NiIWrite: write 80, 1 packs, MESG_IO, hdl 23, data complete
GwFreeMemory: free 000000000BCE6000 (len=192)
GwFreeMemory: act_overflow_size = 268 (- 192)
GwSendToClient: 80 bytes send to conn/target/client 6/1/20
GwSendToClient: decrement conv_no of client 20: 0
GwFreeMemory: free 000000000BCE4000 (len=268)
GwFreeMemory: act_overflow_size = 0 (- 268)
GwIDelR3Conn: idx/conv = ((0/0) | (-1/0)), delete conv 6 from conv-table
GwClearConn: conv_no/tcp_conv_no/sna_conv_no: 3/3/0
GwClearConn: free r3 conv info
GwClearConn: free buffer info
GwFiSearchConvId: deleted 86262062 local, conn=6
GwListInsert: insert elem 6 into conn_free_list (at begin)
GwListInsert: 497 elems in conn_free_list
GwListRemove: elem 6 not in conn_search_list
GwListRemove: elem 6 not in conn_write_list
GwListRemove: remove elem 6 from conn_inuse_list
GwListRemove: 3 elems in conn_inuse_list
*** trace switched off ***

There are no error messages in ST22 and SM21. After reading a couple of posts in SDN; I changed the password of the dialog user to a password consisting only of alphabets and upper case only but that did not help either.

I did go through the SAP Notes ; 704206 and 189077 , however we are not using a saprouter string for the connection. We are using the local gateway connection.

Point to note is that the same RFC connection which we have also set up in our Quality system gives us the remote log in prompt.

I also checked the hosts and services files on both the servers and both seem to have the same entries.

System Details:

Release - 620

Kernel Patch - 640 Patch 414

Please do share if you have any ideas on how to resolve the issue. Do let me know if you need additional information.

Thanks

Surajit