Skip to Content
avatar image
Former Member

Read_Mail can not mark Outlook mail READ flag

Anyboy having issue with Read_Mail action?

I am having no luck in marking Outlook (exchange server) inbox email READ flag after Read_Mail action.

All transaction (including Read_Mail action) works fine.


However when I log in to Outlook email thru MS Office Outlook it is still UNREAD eventhough it is processed in MII.

What is the right configuration to make it work or is this not possible thru MII Read_Mail?

If I uncheck to 'Leave message on Server' the mails disappears from inbox and not even in delete box.

I tried all 'ReadOnly' option as true, false, or blank. None of combination seems working.

Please give me some guiding light.

Best Regards,

Park

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 21, 2014 at 03:58 PM

    Outlook itself keeps track of the opened files. There is no attribute for the message itself at the server level you can set from an external system like MII.

    The Read_Mail or Send_Mail functions in MII mimic a basic POP3 client (if you have the option to leave the mail on the server). IMAP connectivity works directly with the server content and its the preferred way of keeping things interactive.  If the server does not detect when a message is read by any client logging in, accessing the information from it and update the messages statuses automatically, there is little to do in MII to enforce that thing to happen.

    Regards,

    Paul.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you Paul for the explanation.

      My resolution was to log the READ emails in the separate database and compare to the new incoming emails (by time stamps, sender and email subjects) and process only Not READ emails(Brand New) as a workaround. This avoided repeating of reading already processed emails in prior days.

      B.Regards