/scripts/ahub.form.attachments.js
0

SAP WEB IDE for S4H on CAL (AWS): Cannot proxy application requests...Error: socket hang up

Jan 22, 2017 at 06:55 AM

255

avatar image

Dear HANA XSA Gurus and Enthusiasts, I really hope someone can shed any light in this as I am already quite frustrated having not be able to move forward with this very first "Hello World" MTA app since almost a month. By the time I setup the system access the course discussion was already closed :-(

I have already posted the same Q under this link but perhaps it wasn't so clear:

https://answers.sap.com/questions/96787/sap-web-ide-for-sap-hana-hello-world-cannot-proxy.html

My Environment: I run an instance of SAP HANA Express Edition (HXE) on SAP Cloud Appliance Library(CAL). I can access the SAP Web IDE for SAP HANA from my imac as well as win7 notebook but the issue is the same. This shows that the issue is not machine related.

At first I thought it was the very sensitive mta.yaml file but I have even have it checked through YAML validator (http://www.yamllint.com/) which returned "valid YAML".

Attached ( mta-yaml-and-web-error.png ) please find the screen shot of this simple "Hello world" project which can be easily replicated by creating a MTA project "demo" and then a HTML5-module "web".

The error upon clicking the RUN button of the HTML5 module "web" is listed under the section "Application is running". The message between the section "Application is starting" and ""Application is running" can be ignored because in the OpenSAP video of course HANA5 the instructor, Thomas Jung ( https://open.sap.com/courses/hana5/items/33LmE6UJhIXrXf4QXcm71V ) also had the warnings.

Any hint or solution is highly appreciated.

10 |10000 characters needed characters left characters exceeded

I encountered almost the same error,hope someone can help.Thanks .

0

HI Mengxiao, good to know that I am not the only one facing the issue. I have deleted the project demo and recreated it again with the hope of eliminating possible "wrong clicks" and re-RUN it again. Unfortunately the error is still there. :-(

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Andreas Schoesser
Jan 24, 2017 at 08:56 AM
0

Dear Sunaryo SUMIATI,

it looks like the root cause of the problem is that error:

ERROR: Cannot find service uaa in the environment. Details: "No service matches uaa".

I guess that in your application router, you have configured that you want to have request authentication. Therefore, the application router needs to know the location of the authentication component (UAA) and thus you need to bind a service instace of service "xsuaa", plan "default" to your application before starting it. The other option is to make your REST API public so no authentication is needed.

Best regards,

Andreas

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Andreas, vielen Dank for your response. The instructor in the video also had the uaa-error, yet his app ran after that (unlike mine with the "cannot proxy app" error). Can you pls. details a little bit further how to bind a service instance of service "xsuaa", plan "default" to my app? I would then try it out to double check.

Danke

Sunny

0
Skip to Content