Skip to Content
author's profile photo Former Member
Former Member

NWDS import RFC interface for the structure issue??

Hi Gurus,

I'm working on the SAP NetWeaver BPM with NWDS 7.3 SP12 rite now and got confused about the RFC interface structure stuff.

I have a mapping activity defined in the process and the receiver interface needs a RFC. So I go to "Process Modeling" -> "Services Interfaces", right click and choose "Import RFC",type the correct RFC/BAPI name connecting with the SAP ECC system. The issue is that when I finished importing the RFC, went to the "Data Types", the RFC interface namespace shows out but the structure shows seperately with individual segment, so the whole nested RFC interface structure messed up in parallel which is incorrect for the data object and output mapping for later process activities.

Anyone has ran into such kind of issue or experience the same, any solution or suggestion?

Thanks in advance,

Rajesh

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 23, 2014 at 11:13 AM

    Hi Rajesh,

    Could you attach some screenshot in order to understand your issue better?

    Thanks, regards.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      William,

      Thanks for your nice quick reply again 😊

      Regarding the point 2, I add comments as below:

      To assign individual element, do not assign the parent node, but assign each element individually.

      Q:If the occurence of the parent node is 0..1, also dont assign?

      ...if you want to do all the element assignments within HEADER, you can press the right-button on the mouse while dragging the assignment from DO_ZPO_HEADER to HEADER. When you let go of the right-button, you can select "Execute Default Matcher". This will have the same result as assign each element individually.

      Q:When I tried this way, but the right click on the mouse only comes with below choose items, didnt see the "Execute Default Matcher", not sure why, please help to indicate.

      Thanks a lot and Best Regards,

      Rajesh

      rithtbutton.png (3.3 kB)

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.