Skip to Content
Former Member
Jun 19, 2014 at 08:25 PM

Export Hangs Entire Browser


I am using VS2010. When I deploy to my web server (Win 2008 R2, IIS7.0) I can open a report in the Crystal Reports Viewer but when I click the export button the window opens to select file type and the entire browser hangs.

In the status bar it says "waiting for http://<servername>/<appname>/crystalreportsviewers13/js/dhtmllib/empty.html". In task manager the iexplore.exe is chewing up 50% of my processor but still appears to be working. I have to end the process to get control back.

The strange thing is I can log into server, pull up a browser and go to http://localhost/<appname>/<report> and it works fine. As soon as I change "localhost" to "<servername>" it fails!

When I run it through fiddler I get 304: Not Modified on all the crystalreportsviewers13 requests.

I have tried everything I find online that might be close (which is why I am running the crystalreportsviewers13 folder in my app folder, was a suggestion). Has anyone here ever seen this behavior?