Skip to Content
0
Jun 19, 2014 at 12:01 PM

Can't access registered services in gateway cockpit after setting proxies

17 Views

Hi Experts,

We wanted to access one publicly available WSDL through one proxy network by creating OData modeling. But we were not able to deploy the same from Eclipse to Integration gateway cockpit. So we set the proxy settings in the props.ini file available in SMP3 SP03 server path as per Ali's blog How to configure SMP 3.0 to use proxy to access external resource

Now everything works fine , including OData model deployment to SMP server, accessing service document, metadata document.

But, there are few already deployed services in gateway cockpit, when i tried to access them, i get this error in a browser:

<error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">

<code/>

<message xml:lang="en">

Could not instantiate data provider based on class null

</message>

</error>


Also, When i tried to deactivate the registered services, i get this message:


Even, if i try to redeploy existing service from Eclipse by giving different version no, it is not updating in the registered service list.


To work for the same service, i had to recreate everything from scratch which was painful.


What could be the reason for this issue? Proxy settings?


@Ali Chalhoub, @Daniel Van Leeuwen


Regards,

JK


Attachments

deactivatet.PNG (2.9 kB)