Skip to Content
avatar image
Former Member

RFC receiver adapter not getting timed out

Hello Everyone,

I have a scenario like this:

Web-Service --> PI -->RFC (using receiver RFC channel)-->Response back to PI from RFC --> response back to Web-Service

This RFC is taking more than 5 minutes to give response back to PI but still I am not getting timeout in PI.

xiadapter.inbound.timeout.default is set to default value 180000.

Is there any other place where I should check for setting timeout like 10 seconds for rfc receiver channel?


Thanks,

Satarupa

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jun 18, 2014 at 11:25 AM

    Hi Satarupa,

    Please see the link below. Hope this helps.

    XI: Timeouts, timeouts, timeouts....

    Regards,

    Jannus Botha

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 19, 2014 at 08:15 AM

    Dear Satarupa,

    You need to set ICM timeouts at Integration Engine level.

    So go to SXMB_ADM and clic on Specific configuration. Edit table and set parameter as follow:

    Category = RUNTIME.

    Parameters = HTTP_TIMEOUT.

    Current Value = [segs] depens your needs.

    If you hasn't this parameter in SXMB_ADM set this parameter yourself.

    Related link.

    http://itsiti.com/increase-sap-icm-http_timeout-runtime

    Regards,

    Jose

    Add comment
    10|10000 characters needed characters exceeded