Skip to Content
avatar image
Former Member

A JRE or JDK must be available in order to run Eclipse

Hello Colleagues ,

I have started with the SAP HANA Basics course offered at OpenSAP .

I am at my first steps for Installing Eclipse .

Please refer to the following link :-

http://hcp.sap.com/developers/learningtutorial111.html

After Downloading Eclipse , i tried to ran the exe file .

"I got an error A Java Runtime Environment(JRE)  or Java Development Kit(JDK)

must be available in order to run Eclipse .No Java Virtual Machines were found after searching the following locations".

Please let me know if I am missing something ?

Regards

Nitin

JREorJDK.PNG (96.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jun 15, 2014 at 12:58 PM

    You need to install JDK or JRE and configure it in your PATH env variable. See e.g. .

    BTW, next time please do a quick search before posting your question - see also The SCN Rules of Engagement.

    Cheers,

    --Vlado

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 17, 2014 at 02:25 AM

    Thanks for all the Replies to my original post 😊

    When u start Afresh to Learn SAP HANA and installing the tools on 64 -bit windows  :-

    Step 1 : Install JDK or JRE .

    I found a link to share :

    http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

    Step 2 :

    Once you are done with installation, set the env variables. Right click My Computer> properties> Advanced settings->Envoirmental Variables

    Add two system variables:

    E.g. if you have installed JDK . Its rests in the following path

    JAVA_HOME: c:/program files/java/<jdkfoldername>

    CLASSPATH: %JAVA_HOME%/bin

    In My case

    Step 3 : Download and Unzip

    sapjvm-7.1.018-windows-x64.zip

    Step 4 : Download and Unzip neo-javaee6-wp-sdk-2.34.16.1.zip

    Inside your Folder DRIVE:\<Folderpath>\eclipse-jee-juno-SR2-win32-x86_64\eclipse

    eclipse.exe file would be there run it .

    Create workspace and start using .

    Cheers

    Nitin


    Add comment
    10|10000 characters needed characters exceeded

    • Actually, Step 1 and Step 3 are not both necessary - you can use either SAP JVM or any other JDK (including one from Oracle).

      Also, in Step 2 you have to set the PATH variable, not CLASSPATH.