Skip to Content
author's profile photo Former Member
Former Member

BPE Error

There is an Asynchronous call from ECC to PI and using BPM we are calling a webservice synchronously. This scenario is working in all environments except the one where is has been moved recently. We are getting following error while executing an IDoc->SOAP scenario:

Failed checking whether process definition uses given interface - Check Activation in SXI_CACHE and Directory

In SXI_CACHE when we see the Integration Process it has return code 99

Similarly in other environments where it is working the return code is same

We have done a full cache refresh as well but still it is not working

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2014 at 06:26 AM

    Hi Nirmal,

    BPM is not activated due to which getting errors. Try to activate the BPM in SXI_CACHE transation.

    Follow the below link

    Inactive Integration Process (IP) at Run Time

    Regards,

    Krupa

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sourabh,

      Try the below options ,it might work for your case.

      First check with cache refresh .If it doesn't working then go for activation and re deployment.

      From SXI_CACHE activate and redeploy the IP .For this it might ask for a key depends on authorizations for that perticular user ,get it from BASIS and redeploy it.

      SXI_CAHE-->select the IP log -->Click on "Repeat activation" icon-->Deletion(optional)-->Click on Deployment (to redeploy).

      Regards

      Venkat

  • author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2014 at 06:51 AM

    Hi Nirmal,

    Ok, check whether BPM causing the error or SOAP.

    Did you find any message hits in receiver SOAP comm. channel?

    Regards,

    Krupa

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 11, 2014 at 07:45 PM

    Hi,

    Did you check workflow customiizing through T code SWF_XI_CUSTOMIZING. Is everything green?

    Select perform automatic workflow customizing...

    https://help.sap.com/saphelp_nwpi71/helpdata/en/2d/da3142680d5c33e10000000a155106/content.htm

    Hope it helps!

    Ambrish

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.