Skip to Content
0
Former Member
Jun 10, 2014 at 05:01 PM

DI "Database server type not supported" after 8.82->9.0 upgrade

1167 Views

Hello,

We've been using some in-house applications using the DI API for a couple of years, but after our upgrade from B1 8.82 to 9.0 (PL 11), I'm getting the "Database server type not supported" when connecting to the company from client PCs.

I did check other posts mentioning this error (see below; tried the suggested solutions and checks - moving everything to the server is not an option; the applications run on several client PCs).

Important points:

1 - License server, B1 server, and SQL 2008 R2 server run on the same Windows 2008 R2 Server

2 - Running the apps on the server works, only fails from client machines (same workgroup as the server)

3 - Same app worked fine with B1 8.82

4 - We did reinstall (several times) the B1 DI API on the clients (some client PCs have the full B1 client, some only the DI API), same version installed on the server

5 - MS SQL Native Client was also reinstalled several times on the clients, matches version of SQL Server and Native Client on the server (10.52.4000.0).

6 - Tried referencing the server/license server both by name and by ip in the app, also tried switching this in C:\Program Files (x86)\SAP\SAP Business One DI API\Conf\b1-local-machine.xml

7 - DI API seems to connect with the server (there's traffic on port 30000 when the application tries to connect, and if I use wrong values for the license server adress/port in the application, it hangs trying to connect - not getting to the "Database server type not supported" message).

8 - MS SQL Native client is working; the same app also queries (select only) the server using ODBC through the native client, and this still works.

9 - Tried turning Windows firewall off both on client and server, same thing.

10 - Connection properties are:

Server: 192.168.168.150 (also tried name)

LicenseServer: 192.168.168.150:30000 (also tried name)

CompanyDB: (our db name)

UserName: (valid user)

Password: (password)

language: (3, english)

UseTrusted: false (also tried true, with/out db user/pass)

DbServerType: (6, MSSQL2008) (also tried from 0 to 7, 0 returns "No database server type specified", all others return "Database server type not supported")

DbUserName: sa

DbPassword: password

11 - Windows Server and Clients are 64 bits, but SAP B1 and DI API are 32, application using the DI is also 32. MS Native Client is 64 (does not allow 32 to be installed on the 64bit client PCs). Tried installing the 64bit DI API, but then the 32bit application cannot initialize the ActiveX component.

Again, everything worked fine before upgrading from 8.82 to 9.0, and still works if ran on the server.

May or not be related: Crystal Reports cannot list the databases after the upgrade to 9.0 too.

Could this be related to SLD? My SDK 9.0 help files still refers to the 2007 DI API in the "Connecting to SAP Business One Database", so maybe there is something that needs to be changed related to SLD or something else for 9.0 which is not in the help yet?

Thanks in advance for any help!

Joao S Veiga