Skip to Content

Problen when I try to activate my message mapping

Dears,

I have a problem when i try to active my message mapping. This mapping is already activated since 2012, but when i try to access in edit mode and I try to active (Without any change), returns fail.

Before press edit mode button:

  • Check:

No errors found during object check

  • Test:

09:42:02 Start of test

Execution of mapping on server took 57 milliseconds Executed successfully

09:42:02 End of test


After press edit mode button (Witout any change):

  • Check:

Check Result for Object XXX

Source text of object Message Mapping: XXX| http://XXX has syntax errors:

Source code has syntax error:

  • Test:

09:44:46 Start of test

Source text of object Message Mapping: MM2SUSOrderCreate | http://sap.com/xi/SRM/SupplierEnablement/Global has syntax errors:

Source code has syntax error:

09:44:48 End of test

why does this happen?

Regards

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Jun 10, 2014 at 08:20 AM

    Hi Alvarom

    are you changing a standard SRM content for PI?, have you checked the SRM content version with your PI version is updated?

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 10, 2014 at 08:24 AM

    Hi Alvaro,

    Can you please check that your data types and message types are all active before you try and activate your mapping?

    Please can you also check your cache.

    Regards,

    Jannus Botha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 10, 2014 at 09:08 AM

    This scenario is OK since 2013.

    I haven't made any change in other objects (Data Type,Message Type, ....), only I have pressed "edit mode", like it see in pictures

    I will review the cache but I am not sure that be the problem.

    Any more idea?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Alvaro,

      First lets try and give it a nice full cache refresh.

      2nd. Can you still access all the components for example the data types etc? Nobody deleted it by mistake?

      3. Have you tried to restart PI?

      Regards,

      Jannus Botha

  • Posted on Jun 11, 2014 at 07:15 AM

    Hi Jannus,

    Thanks for your response.

    I have analyzed the scenario and I find errors in my java functions when check mapping step by step with "Display Queue" (Function tag in MM).

    This functions was ok when we had XI, but now with PI, It returns error.

    There is any change after the upgrade to pi with respect to java methods or in relation to java mapping?

    @Iñaki

    I haven't seen your answer. My basis team import content version in PI, Is it neccesary doing the same in SRM?

    Guide about content version:

    How to import SAP content into the PI ESR - Process Integration - SCN Wiki

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.