Skip to Content
avatar image
Former Member

Calculated view with input parameters

Hello there.

I've created a calculated view with input parameters, which I am going to call  it  'VIEW_A'.

This view has been working just fine.

But now I have to create another calculated view and import the last one(VIEW_A) in a projection.

But I got a error when trying to see the data content. 

It says :

Error: SAP DBTech JDBC: [2048]: column store error: search table error:  [6968] Evaluator: syntax error in expression string;expected TK_ID,parsing '"DT_DOC_MES_ANO" >= [here]and "DT_DOC_MES_ANO" <='

At the 'Problems' panel it says the all the input parameters are unmapped.

What Am I doing wrong?  Sorry but I am kind new at SAP world.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 02, 2015 at 08:09 PM

    Hi,

    I think, you have not mapped input parameters properly. Please do following steps to map input parameter from VIEW_2 to VIEW_1

    • Go to semantic layer of VIEW_2
    • Click on "Parameter/Variable" tab which is last tab
    • search for following icon.
    • select "Views for Value help for variable/input parameters"
    • Map the IP with current view.

    I hope, this will help you.

    Regards,

    Vikram

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 31, 2014 at 05:55 AM

    http://scn.sap.com/message/15489475Hello Tiago,

    Could you please let me know if you're able to resolve your issue, I'm getting the similar error when I'm passing alpha numeric values as parameter via my SP.

    Thanks for your help in advance!

    Regards,

    Sathish

    Add comment
    10|10000 characters needed characters exceeded

    • hi abhishek, I am using my calculation view directly from HANA and calling it from a stored procedure within HANA. my issue which seems similar to yours was due to the single quotes around the input params - I didn't have any @prompts so mine was direct call. make sure your input param is wrapped with 1 single quote at the beginning and end... and if you have multiple values such as in my case, you need to have 2 single quotes in between values and comma such as 'value1'',''value2'  this is how I solved my problem - again.. I didn't have a @prompt or universe. hope this helps