Skip to Content
author's profile photo Former Member
Former Member

NWDS Deployment Error

Hi All,

We are implemeting a NWBPM process for the first time and we followed the below link:

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/307336b8-098c-2d10-be9c-d41ae345f0ff?QuickLink=index&…

We added the PO server through management console too.

But during deploying the process,we got errors.

[Error ]: [#0]: Deployment Exception during deployment phase [DeploymentException], cause=[ASJ.dpl_dc.001085 Operation [deploy] of [demo.sap.com_dc_XXXX] failed]

SAP PO version is 7.31 EPH 1 SP 8, while that of NWDS is 7.31 EPH 1 SP 10

Can you please let me know:
-Is it version incompatibility?
-Is it relevant to admin rights or something? Also the admin rights, if any?

Also possibly the steps to integrate SAP PO with NWDS

Thanks in advance

Regards,

Atreyee

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jun 06, 2014 at 02:13 PM

    Hello,

    You should have pasted complete error description.

    Anyway, i think the error message is because the NWDS version which you are using is not the same as that of ur Server. Install NWDS 7.31 SP 10 and then build and deploy BPM.

    Thanks

    Amit Srivastava

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Amit Srivastava

      Hi Amit,

      All the details were provided. we are able to successfully deploy now. We just needed to work with equal or lower version of NWDS. In the version, we need to take care that the SP and PAT of the NWDS is not higher than than of SAP PO.

      Ex- If the version of your PO is 7.31 SP 08 PAT 0000

      You cannot deploy SAP PO server with 7.31 SP 09 PAT 0000 nor 7.31 SP 08 PAT 0013.

      You have to consider 7.31 SP 08 PAT 0000 or less than that.

      Thanks and Regards,

      Atreyee Chandra

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2014 at 04:30 PM

    hi,

    >> -Is it version incompatibility? No.

    Its recommended to use higher sp of the nwds.


    br, avinash

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2014 at 04:07 AM

    Hi All,

    Thanks for your help. The error is resolved. It was due to Higher version of NWDS (version including SP and PAT needs to be considered).

    On checking the stack throughly I came up with the error:

    "The given process model was built with a NWDS or development track of a higher version than the target runtime. Revision number of built process model: 4.4. Revision number of process runtime: 4.3. Please refer to SAP note 1600131 for details......"

    One thing learnt:- First thing you need to check is the exact version of SAP PO including the Service Pack and Patch Level.

    You can check this from:

    1. Directly through the URL:: http://<host>:<port>/sap/monitoring/SystemInfo

    2. From http://<server>:<port>/ -> System Information -> Component Information

    The NWDS should be either less than or equal to the version of SAP PO. You need to check all the details including Service Pack and Patch level.

    *** In our case, although the SAP PO and NWDS are of same version i.e 7.31. But the higher SP and PAT of the NWDS was giving the error.

    Regards,

    Atreyee

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.