Skip to Content
author's profile photo Former Member
Former Member

B1IF for-each with a condition

Hi Experts,

I am struggling with a B1IF condition inside a for-each call.

I have 40 others messages that works correctly with the same structure but for this one even when the condition matches it does not go through to my condition.

Capture.JPG

Please assist...

Kind Regards,

Brenden Draper

Capture2.JPG (45.5 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 02, 2014 at 09:57 AM


    Capture.JPG (73.8 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi All,

      I have deleted my scenario step and copied the one that works and it solved the problem.

      But I still do not understand why it happened because I tested the result of my condition and it returns what is expected.

      When I remove the /*[] from the condition it works but obviously it says your message is not well formed because no data is returned then but when I put the /*[] back it does not meet my condition for some reason.

      I will leave this call open for now until I am sure why this happened.

      Kind Regards,

      Brenden Draper

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.