Skip to Content

SAP WCEM Salestransactions Item Extension.

Hi

I'm trying to get Custom field into Checkout Page of SalesOrder. I've done necessary implementation by extending ItemBeanImpl and Viewhandler classes. I've also implemented BAdi in the back end to send data to Web-shop. I've also updated the UI-Repository & factory-config xml. Inspite of all these the data is not coming to front end. It is displaying a message 500 internal server error in the output text.

Can anybody help me out finding a solution for it?

Regards

Karteek

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 02, 2014 at 05:39 AM

    Hello, Karteek

    Please have a look additional information about the issue in the log.

    Denis

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 02, 2014 at 09:29 AM

    Hi Karteek

    Like what Denis, you would have to check the log in the NWA of your runtime system. I hope you will be able to get there. Check under Developer Traces and you should be able to pick up what the issue is.

    If you cannot figure out what is wrong, please provide details of the log so we can be able to help .

    As an alternative to the solution, you can use extension fields/data and provide the necessary extensions and implement the BADI in your backend system to provide the necessary data. I have done this only in the scenario where you are using the backend cart rather than the java cart.

    Regards,

    Brian

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member karteek k

      Hi Karteek

      When you get that 500 error, the log is almost always there. Can you perhaps just send a screenshot of the Developer Traces view of the log.

      I personally find it much easier to use extension fields especially if you are dealing with fields that are not part of the standard structure on the CRM side - assuming ofcourse that you are using CRM as your backend system. If you would like to try this solution, I can give you pointers.

      I am certain that there is an entry in the log that points you to the issue.

      Regards,

      Brian

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.