Skip to Content
0

Sales New Billing plan, Contract dates don't get populated.

Jan 20, 2017 at 01:38 PM

150

avatar image
Former Member

I want to create a new periodic billing plan for a contract. The billing of the contract will be done directly based on the contract, the billing is order related. The billing should be done at the end of every month.

I created a new billing plan C0 (periodical with the following settings):

The 90 numbers are used because someone has change the standard of SAP, the 13, 14 and 52. They have been set equal to the standards.

  • Start date 90 (13):
  • o Base Line date 02 contract start date
  • o Contract data Marked.
  • End date 91 (14):
  • o Base Line Date 09 contract end date
  • o Contract data Marked.
  • Horizon 95 (52):
  • o Baseline date = 01 Today’s date
  • o Time period = 1
  • o Time Unit = 4 Year
  • o Last of Month = B Last of the Month
  • Next Billing date 51
  • o Baseline date = 07 Billing date / Invoice date
  • o Time period = 1
  • o Time Unit 3 = Month
  • o Last of Month = B Month
  • Default Date Category = 01.
  • Online Order X
  • FCode 0002.

I assigned the Billing plan to the new contract type and I did the same to the item category, that is Relevant code I “Order relevant billing - billing plan” and my new billing plan type C0.

Now when I create a new contract valid from 1-1-2017 (in the past) till 31-12-2017 for a customer and a material and when I go to the header data -> Billing plan I got a message no. V2406 “Start date billing plan: Base line date 90 not set, the same applies to the end date.

And this is the result.

If I enter the Start date 1-1-2017 and End date 31-12-2017 manual then the dates are proposed.

I have a few questions now:

  • What is the cause of the problem?
  • What customizing or master data setting is missing or might cause the problem?
  • How can I debug the determination of the dates?
10 |10000 characters needed characters left characters exceeded
Former Member

billin-plan-i.jpg

billin-plan-i.jpg billin-plan-ii.jpg

Herewith the pictures

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Mar 24, 2017 at 10:09 AM
0

Hi there,

Problem is solved. It was a new contract type (Z order type), transaction group 4 Contract, defined by me and somehow I needed to confirm that contract data is allowed. Define in the order type under section Contract "Contract data allwd." = X? Very strange but it works like a charm now.

Share
10 |10000 characters needed characters left characters exceeded
G Lakshmipathi
Mar 02, 2017 at 04:15 PM
0

Check whether you set any date for your Billing Plan in OVBM where once you click "Maintain date", you can see this.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 24, 2017 at 11:46 AM
0

Hi G Lakshmipathi,

Please read my initial question, there you can see I created a Billing plan CO (OVBM) with correct date rules etcetera, everything was already in place. Just one setting was missing.

Problem solved.

Share
10 |10000 characters needed characters left characters exceeded