Skip to Content
avatar image
Former Member

Workflow stuck due to No Agent found

Hi experts,

I am currently facing one issue in the production environment.

A workflow was moved into Production few days back.

But the foreground tasks (2 of them ) were not made 'General task' for few days until now.

Now all the work items created by this workflow till date, in all of them , all the Dialog work items were not forwarded to their respective agents since the tasks were not maintained as General task. That means when they are checked in workflow log, it says 'No selected agents'.

But now I have made them as General task.

But the question arises, the work items which have been created till date, how can they be forwarded to their respective agents?

The workflow is 2 level.

Next question is: If the 1st level is completed manually, will the 2nd level approver now properly get the work item? Since the task have been set as General task now?

Please help.

Regards,

Pranita

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    May 30, 2014 at 09:33 AM

    to restart workitem that didn't have an agent assignment you can use swi2_adm1/2.

    and as for the second question, the agent assignment is calculated separately for every workitem so it should work well now.

    also, if you are not using rules, how are you doing the agent assignment, directly to an org unit/position/user? even if it is only one position I would recommend using rules because you might have problems redirecting the workflows if the position is changed if you don't.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 30, 2014 at 09:45 AM

    Hello Pranita,

    Hope u r doing good.

    Forward current work item by SWIA and 2nd level will work perfectly.

    Also if multiple user are there than change setting for forwarding

    to multiple user.

    Which workflow we are talking about here ?

    Thanks and regards,

    Aditya

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Aditya,

      Oh ok I got it.

      I tried a work around that I mentioned in my previous reply.

      waiting to check the same in Prod now lets see...🤣

      regards

      Pranita

  • May 30, 2014 at 09:15 AM

    Hi,

    you can use SWI1_RULE , after that click EXECUTE AGENTS RULE, to determine agent again. Or you can directly forward usin SWIA

    Add comment
    10|10000 characters needed characters exceeded

    • hI,

      I think you should have use that SWI1_RULE. Here Rule means not only user for Agent determination usin Rule.

      Here Rule means it will again retermine agent based on responsible agent and possible agent.

      If you are not maintain any responsible agent in step , and make the task as general. Then all agent will get the workitem. 😊

  • May 30, 2014 at 09:37 AM

    Hi Pranita

    use the admin transaction SWIA to forward those Items to the correct agents.

    regards,

    Modak

    Add comment
    10|10000 characters needed characters exceeded