Skip to Content
0

UWL items are not syncing properly?

Jan 20, 2017 at 12:28 PM

229

avatar image

We are using UWL from portal to SRM backend.

UWL is fetching list but the problem is new work items are not getting reflected .

Whenever i clear portal uwl cache new items appear, but here also once i select any item again after opening they disappear.

I have checked RFC destination ,working fine.

In WebFlowConnector-

In connector while re- registering i am getting following warnings--

WebDynproApplication value not found for task TS00700049 in system XXXXX

Portal Component value not found for task TS00700059 in system XXXXX

WebDynproApplication value not found for task TS48007915 in system XXXXX

Furthermore whenever i try to specify Delta Pull Channel Refresh Period, i cannot and get following warning-

The backend of system XXXXX is not configured for optimized delta pull.

In backend the job which is running program RSWNUWLSEL is getting cancelled.

Please help , i am rookie in Portal and working alone.

It would be a great help.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Santarshi Samanta
Jan 21, 2017 at 12:18 PM
2

Hi

As per the error message that you have given

"WebDynproApplication value not found for task TS00700049 in system XXXXX

Portal Component value not found for task TS00700059 in system XXXXX"

I came across a similar discussion, can you refer to it and check if it works for you ro not.

https://archive.sap.com/discussions/thread/1354839

And as per the error message "The backend of system XXXXX is not configured for optimized delta pull." Refer to the below KBA

1577545 - Handling Delta Pull Issues - "Could not verify if the backend of system is configured for optimized delta pull"

And also for more information about UWL refresh refer to the below KBA

2024498 - Clarifying UWL Refresh Options

Regards

Santarshi Samanta

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Santarshi,

My warning issues and delta pull issues are resolved, i was missing delta scheduling.

I configured optimized refresh but still uwl refresh is not working, work items are not coming automatically, they arrives only if clear uwl cache.

If i click on refresh nothing is happening. That too also disappears whenever i open list item even after without taking any action.

Thanks for your valuable response. Please help.

Regards,

Thava

0
Armando Zaro
Jan 24, 2017 at 08:32 PM
1

Hello!

Along with the information mentioned by Santarshi, also please notice that the problem you're having might be caused by an inconsistency of the XML files which you've got in the UWL and the value of the following properties in the UWL iView being used:

  1. sap_uwl_viewname
  2. useNavigationId

You may check also based on the following SAP Community Wiki:

https://wiki.scn.sap.com/wiki/x/c4WvE

Following is the documentation for the above mentioned properties:

https://help.sap.com/saphelp_nw74/helpdata/en/4a/ee9c6588946d62e10000000a42189c/content.htm

You can also test with the default UWL iView located under the Content Provided by SAP:

http://<server>:<port>/irj/portal?NavigationTarget=pcd:portal_content/com.sap.pct/every_user/general/iViews/com.sap.netweaver.bc.uwl.iviews/com.sap.netweaver.bc.uwl.uwl_iview

Does the same problem also happen?

In case the problem doesn't happen when accessing through such iView, it's a clear indication that the symptom you're observing is caused by incorrect configuration of the properties above mentioned.

Kind regards,
Armando Zaro

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Armando,

XML file is properly maintained.

Issue reported few days back, before that UWL iview was working fine.

Thanks for your response.

Please suggest.

Regards,

Thava

1

Hi Thava

Eventually it might be some bug for which a fix is already provided.

What's the version that you've got for UWLJWF software component?

Please check SAP KBA 1757810 on how to retrieve the Software Components' versions list.

After checking the version of UWLJWF, search if there is any missing patch within your SP. You can do this by following the KBA below:

#1771843: How to identify and search the latest patch level for a Netweaver Java Component

Let me know about your findings.

Regards,
Armando

0
Thavamohan SAP Team Jan 31, 2017 at 08:38 AM
0

Hi Armando,

Please find the detail.

UWLJWF sap.com SAP AG 1000.7.40.11.0.20150402183800

I also matched with quality and there also the component is similar and there uwl is working fine.

Additionally maximum components are on patch 0 only.

Please suggest.

Regards,

Thava

Share
10 |10000 characters needed characters left characters exceeded