Skip to Content
avatar image
Former Member

Parameter not passing from Report to Sub-report

Hi all

I am having an issue with a crystal report..Works great when I run it in Crystal reports...but when i import it into sap...i get the error:

Cannot find parameter field Pm-Command.CardCode in subreport Discounts.

its basically a statement report..with 2 sub-reports...To bring in paid invoice, and discounts(posted as journals)

for both im bringing in the CardCode field.

I checked afew threads on the forums..to check if "Reimport when Opening" is unticked

Any Ideas

Its Crystal 2011.

SQL 2012

SAP 9.0 PL 07

Thank you

Jerusha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 23, 2014 at 01:32 PM

    Hi Jerusha,

    Try doing the links to the Subreport again.

    Right-click the Subreport > Select Change Subreport Links > Move the CardCode field to the Pane on the right > Link it to the field in the Subreport.

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Prathamesh Acharya

      Hi Prathamesh

      I will give that a go.

      yes i am sure the reports are working in crystal.

      I tested it with a  couple of business partners and it works out the amounts exactly to what it is in Business One.

      I havent used a report with sub reports before..Not to sure if the patch could be causing an issue.

  • avatar image
    Former Member
    May 28, 2014 at 03:05 PM

    Hi All

    I managed to get this right.

    I had too many date parameters (of the same kind)

    I linked the main report to the sub report and it now works in SAP.

    Thank you all for your help.

    Jerusha

    Add comment
    10|10000 characters needed characters exceeded