Skip to Content
0
Nov 23, 2005 at 09:07 PM

DB Connection issue

27 Views

Hi all,

I have an issue in a new Production Portal Installation that I can't figure out so I thought I would run it by some of you guys.

This is EP6 SP13, NW6.4 SP13 in an AIX 5.3/Oracle environment. When I execute "startsap" I get the following errors. (Note, the startsap script runs through and start the Database as well as the SCS instance before failing under the JC32 instance startup)

Form all JdbcCon.log files (one in …JC32/j2ee/cluster/bootstrap, one in $HOME, and one in JC32/work) I get the following error:

Error: Couldn't connect to DB

java.sql.SQLException: Io exception: The Network Adapter could not establish the connection

The database is running and available. And the listener is running. I can connect using SQL*plus from the eppadm login session as well as (of course) from the oraepp login session.

I am also seeing the following error message from the log_bootstrap_ID3276477.0.log in JC32/work:

[Nov 23, 2005 12:13:31...] -


[Nov 23, 2005 12:13:31...] Bootstrap MODE:

[Nov 23, 2005 12:13:31...] <INSTANCE GLOBALS>

[Nov 23, 2005 12:13:31...] determined by parameter [ID3276477].

[Nov 23, 2005 12:13:31...] -


[Nov 23, 2005 12:13:36...] Exception occured:

com.sap.engine.bootstrap.SynchronizationException: Database initialization failed! Check database properties!

.

.

.

-


==[ Caused by: ]==----


com.sap.engine.frame.core.configuration.ConfigurationException: Error while connecting to DB.

.

.

.

Caused by: java.sql.SQLException: Io exception: The Network Adapter could not establish the connection

Any idea of what this might be?

Is there a program on the Java side like R3trans -x where I can test a DB connection to see why it is breaking/not-reaching the DB?

Additional info, I have checked $PATH which is good (compared with a working TST). I checked $LIBPATH which is good (compared with a working TST). And, I compared env as well with no differences. (there were a couple of differences which I fixed but with no resolution).

Thanks a bunch guys,

-ok