Skip to Content

deployment of JAVA-Patches with SUM failed, MOPZ has downloaded malicious code

some time ago, we did an upgrade of our doublestack PI-System from NW-PI-700-SPS18 to NW-PI-731-SPS05.

Now, i wanted to upgrade this PI-system from NW-PI-731-SPS05 to NW-PI-731-SPS07.

with SUM 1.0 SP10 PL4 we are now failing in the Execution-phase (Downtime):

Error in phase 5.6. execution (downtime) of the JAVA-Part

F ********************************************************************************

F *** ERROR => Node 'deployment' failed with exit code 67.

F ***

F *** Please see section 'Failures in the 'deploying offline components' phase'

F *** in SAP Note 1316652 for additional information and trouble shooting advice.

F ********************************************************************************

and the instance could not start up anymore !?


in sap-note 1316652 there is mentioned a separate sap-note 1550641 for this error

http://service.sap.com/sap/support/notes/1316652

in sap-note 1550641 - Update fails-Node 'deployment' failed with exit code 67.

http://service.sap.com/sap/support/notes/1550641

Solution:

A fix cannot be deployed as a patch, because the deployer itself is broken.

The solution is to reset a back up state of the system, to download the new version of the stack from SAP Marketplace, and to rerun the update/upgrade procedure.

i downloaded the patch-stack (with Solman MOPZ) some days ago,

so MOPZ did download the malicious code of deployment components..... ?!

so what to do?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on May 20, 2014 at 03:21 PM

    Hi Christoph,

    "Malicious code" is a bit extreme, don't you think? Anyway, no, there's no malicious code here, there's just a bug in one of the components. Granted, the language in Note 1550641 is not the most clear, but basically what it is saying is that there is a known bug (with a fix available) for the offline deployment tool. However, because the bug is in the tool itself used for deployment, you can't just patch it and move on. Instead, you must reconfigure your stack to include the updated version of the offline deployment tool and start over.

    However, I don't really think this is your problem. That fix was incorporated into stack 3 of NetWeaver 7.30 a couple years ago, and you are well past that. So, take a look in the log files suggested from the other Note, 1316652, and see if you can find more clues to what went wrong. Those log files are:

    • dev_jstart*
    • dev_deployment*
    • std_deployment.*
    • jvm_deployment.*

    See if you can find errors in one or more of those. If you do, post the relevant section of the relevant log here.

    Or, do as the Note suggested, and open a Customer Incident with SAP Customer Support against component BC-JAS-DPL and attach those log files to the Incident.

    Regards,

    Matt

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Christoph Ostrop

      Hi Christoph,

      Am facing the same issue while upgrading my PI 7.1 (Dual Stack System) to 7.4 Dual.

      During Execution phase - Deploy Software Components Step i have also struck with same issue.

      My JAVA is not getting started and am getting the below error.

      [Thr 2460] Sun Apr 24 08:39:09 2016

      F [Thr 2460] *** LOG => Process snapshot stopped (pid 5136).

      F [Thr 2460] *** LOG => Instance state is "Deploying offline components" (STOPPING @ 0, INACTIVE).

      F [Thr 2460] *** LOG => Run level 1 completed.

      F [Thr 2460] *** LOG => Instance state is "Some processes failed" (STOPPED @ 0, INACTIVE).

      I [Thr 2460] MPI: dynamic quotas disabled.

      I [Thr 2460] MPI init, created: pipes=4000 buffers=2718 reserved=815 quota=10%, buffer size=65536, total size MB=170

      I [Thr 2460] *** ERROR => FcaInit: already initialized [fcaxxcomm.c 956]

      I [Thr 2460] *** ERROR => EvtRmMgt: Evt Mgt Table not init'd [evtnt.c 255]

      I [Thr 2460] *** ERROR => ShmDelete: Invalid shared memory Key=62. [shmnt.c 753]

      I [Thr 2460] *** ERROR => ShmCleanup: ShmDelete failed for Key:62. [shmnt.c 872]

      I [Thr 2460] *** ERROR => ShmCleanup(62) failed 1 [mpixx.c 4609]

      F

      F ********************************************************************************

      F *** ERROR => Node 'deployment' failed with exit code 67.

      F ***

      F *** Please see section 'Failures in the 'deploying offline components' phase'

      F *** in SAP Note 1316652 for additional information and trouble shooting advice.

      F ********************************************************************************

      F

      F [Thr 2460] *** LOG => exiting (exitcode 22002, retcode 1).

      As you have mentioned i have deleted my sapxmltoolkit.jar from my bootstrap folder and tried starting my JAVA instance from MMC but no luck.

      Also tried resuming back my SUM, Since JAVA is not UP am getting the same issue.

      Can you kindly brief on what have done ?

      After deleting can you list out what all required restart ?

      Am struggling at this phase from last 3 days.

      Would be great if you can help me with the detailed actions you have performed.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.