Skip to Content
0

Error/bug when removing SC from development configuration

Jan 20, 2017 at 07:18 AM

280

avatar image

Hello!

We have some SCs for NWDS development in our development configuration.

When I try to remove one of these, some other SCs also disappear even though they are not associated with SC I want to remove. After this I have to add them once again, it is annoying.

Is it a bug? What can be done about this?

Using SAP PO 7.4 .

Best regards,

Andrey

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Szabolcs Renyo
Feb 01, 2017 at 04:32 PM
2

Hi Andrey,

As we assume this behavior can caused by the Product Definition. I think there is connection between your SCs via this settings.

You can test if you tick off the "Product Definition" in CM Services and try to delete the SC again.

If you still have the same behavior please navigate to the SLD select the SCs --> tab "Products" and select your product. After navigate to tab "Product Definition" and make some screenshot (with both SCs).

Best Regards,
Szabolcs

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Szabolcs.

Excuse me, but where exactly (in which service) should I uncheck "Product definition" checkbox?

I thought it only indicates that the software component contains definition of its SLD product.

Both mentioned SCs are the only SCs in their products. Thus, each of these SCs contains its product definition (as far as I know, if definition is missing in all product SCs then it is impossible to use its SCs for NWDI tasks).

Here are SLD screenshots:

sc045-def.png (28.1 kB)
v185-def.png (27.2 kB)
0

Szabolcs, hello once again.

I tried some experiments. It looks you are right about product definition.

To make some summary: when I remove any SC, not only it disappears but also _ALL_ SCs with "Product definition" flag also disappear. Other SCs (without flag) remain in configuration.

However, there is a question. If I have a product with only one SC, which contains product definition and is used for NWDI development, I will face the described issue when removing any other SC. Is it a bug or a feature? Probably SAP did not want us to combine definition and development purposes in one SC, but it still lets us add such SCs into configuration.

Best regards,

Andrey

1

Hello Andrey,

I found some documentation about Product Definition for you:
https://help.sap.com/saphelp_nwpi711/helpdata/en/16/c12c4c376444b09efd7e85fc8cd773/frameset.htm
https://help.sap.com/saphelp_nwce72/helpdata/en/49/0efe80f6934a18e10000000a42189b/frameset.htm

As I see this option is responsible to organize your SCs. This was the reason why removed all of them if you deleted one.

I would suggest that don't use this parameter. I think you will be able to use your Software Component Definitions without any error in NWDI.

I hope I could help you.

Best Regards,
Szabolcs

2

Hello Szabolcs.

You mean that it is possible to create a product and an SC for NWDI usage without product definition?

As far as I remember, it appeared to be necessary when I started NWDI development. Though I may be wrong.

Best regards,

Andrey

0

Hello Andrey,

Yes, I think exactly for this. Is I know it is not necessary to use Product Definition. Please try to use it without this future and let us know the result.

Best Regards,

Szabolcs

2
Milen Dontcheff
Jan 25, 2017 at 12:34 PM
2

Hello Andrey,

I would suggest to provide of a screenshot from the Build-Time dependencies in the SLD.
It would have been a very interesting phenomenon had not been any connection defined there.

Regards,
Milen

Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hello Milen.

This is for SC_V185_SC001_SALESREPSMS (the one which I intended to remove from configuration):

There is one more row below - DI BUILD TOOL 7.40 (not visible here).

And this is for SC_KOMUS_SC045_CAMPAIGN (the one which was also removed though I didn't want it):

0

can you see some cyclic references? I mean something like A has dependency to B and B to C, then C again to A ?

0

I think there are none of those. Both our SCs depend on standard SAP SCs, and nothing depends on our two SCs.

0

quick heads up: I contacted some colleagues for checking I hope they get back to me soon

0

Thank you Ervin, looking forward to getting a solution.

0

Hi,

I just doublechecked with my colleagues here, Szabolcs (who replied for the first time) will soon provide some more hints which hopefully help or at least brings closer to the resolution.

Cheers,
Ervin

1
Show more comments
Szabolcs Renyo
Jan 23, 2017 at 02:42 PM
1

Hello Andrey,

Could you please attach some screenshot about how you try to delete these SCs?

Additionally, please provide a list from your SCs before and after the deletion.

Thank you and best regards,
Szabolcs Renyo

Share
10 |10000 characters needed characters left characters exceeded
Ervin Szolke
Jan 25, 2017 at 07:01 AM
1

Hi,

I agree , couple of screenshots would help indeed, and also some examples what is the name of the SCs you are trying to remove. Are you sure there are no relation between these? Another guess of mine is that you attempt these steps in NWDI, not in NWDS. If so, there is a filter button in the track config (in landscape config) near to the table that displays your SCs, it would be worth to check all possible settings there to find out whether there are some leftover SCs that are not displayed in other filter modes.

Thanks

Ervin

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi colleagues.

I do this in NWDI, you are right. I just meant that those SWCVs will be used as compartments for BPM DCs.

Thank you for your attention, we'll try sharing some screenshots.

Best regards,

Andrey

0

ok, thanks, will keep the eye on my notification stream :)

0

I selected SC_V185_SC001_SALESREPSMS row (visible on screen 1) and clicked "Remove SC" button.

After that not only selected row disappeared but also SC_KOMUS_SC045_CAMPAIGN did (screen 2).

screen1.png (33.9 kB)
screen2.png (28.8 kB)
0
Andrey Petin Feb 08, 2017 at 01:20 PM
1

I removed product definition property from SCs which are being discussed. And yes, they stopped disappearing :)

Thank you Szabolcs. I will not set this flag in my future components and I hope they will work fine.

Now closing the question.

Best regards,

Andrey

Share
10 |10000 characters needed characters left characters exceeded