Skip to Content
avatar image
Former Member

Time-dependent attribute not working with BWA

Hi,

I have master data time-dependent navigational attributes and these are not working when i run the query with BWA.

In RSRT, when i run with out BWA query is showing results.

I tried building index on  time-dependent attributes table using SAP note 1789310 (RSDDTREX_SINGLE_TABLE_INDEX)

Steps i followed:

Dropped BWA index on a cube that has this master data object zmaterial

Recreate BWA indexes on the cube(not yet filled)

Run the program RSDDTREX_SINGLE_TABLE_INDEX with cube name and for master data tables /BIC/QZMATERIAL /BIC/YZMATERIAL

When i run the program it dumping and when i check st22, the message i found is INVALID_INPUT TABLE NOT FOUND /BIC/QZMATERIAL

I checked table /BIC/QZMATERIAL it has data, i can see data in it. I checked if it consistent or not in SE13 and it is consistent.

I tried checking SLG1 and i can't find any logs.

Appreciate any help on this.

Thanks,

Raghu

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    May 16, 2014 at 10:50 AM

    Hey Raghu,

    Please check the md daemon job for any failures on Material index.

    If there are errors, please use single table index program to index them. Once they are done, you can try refilling the BWA indexes for your cube.

    Please do share if this works/ not.

    Regards,

    Sheen

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Sheen for the response.

      Problem is fixed:

      Issue : BWA indexes for few time-dependent Nav attributes are corrupted, hence when time-dependent nav attribute is used to drill down in query, when these records are present, query outputs "no applicable data message". Query runs fine without BWA.

      Raised to SAP since RSDDTREX_SINGLE_TABLE_INDEX is giving ABAP dumps when tried to build indexes on S,Q,Y tables.

      SAP Suggestion : Rebuild for S,X,Y tables using program. Note 1789310


      Still that didn't fix the issue. Program was giving dumps when tried to execute for S,X,Y tables.

      I ran the program for S table and that went fine, in job log i see it recreated indexes for S,X,Y tables and that fixed issue.


      Closing thread.


      Thanks,

      Raghu