Skip to Content
Former Member
May 08, 2014 at 12:29 PM

Unable to connect to OData service from Eclipse Juno + Kepler


Dear all,

I want to utilize the GWPA OData Toolkit for Java to consume an OData service running in NetWeaver Gateway in a Java application. When I try to install GWPA in Eclipse Juno via "Install new software", I can select the required components, confirm the License agreement, press Finish and... get the error below:

Almost all of the missing bundles belong to SAP - how comes? The Proxy settings are okay, as I can load in the Available Software Sites preferences (same for Eclipse Juno site). At the first trial I received and error about missing components org.eclipse.emf.transaction... - I got over that by installing Eclipse EMF plugins from the respective download location via Install new software.

As an alternative I tried Eclipse Kepler (I know it is not officially supported for GWPA). Here the installation is successful, but when I try to generate a proxy class for an OData service, I can not enter credentials for basic authentication anywhere, there is no dialog comming up. Consequently, I get an error:

I tried to hand over credentials within the URL as http://<user>:<password@<server>..., but that does not work. We haven´t prepared SSL access to the Gateway, as external access is only done via an SMP server so far.

Does anybody of you have clue how I could solve this?

Thanks a lot,



Not_authorized.jpg (61.4 kB)